Download

Static on Metals

I’ve been casually investigating this odd problem that I’m having with baking lighting onto metals. I keep getting dark blue areas on metal surfaces regardless of lightmap resolution or UV channel layouts. Any help would be appreciated.

In the following picture, the left one is at a resolution of 128 and the right is at 512. I’ve noticed that these spots don’t show up on the dark sides of them.

Hi!

Could you show us your lightmap uv layout?

Here is the UV in this picture. I’ve tried spacing them out better and giving more space to the metal parts only to get very similar results. What typically causes this, anyway? Islands being too close? Low resolution?

I’d say it’s the lightmap uvs…
If you want to use lower resolution lightmaps then yes you should keep more space between the islands!
What I would do in this case is keep the whole pole together (now it’s in 3 pieces). The metal part is almost good except the flat parts have their cuts in a wrong place! I would select one side and have a flat map! Like this it would keep it together and wouldn’t have those seams…

Are you saying that I should have each side connected to itself instead of being separated (the little wings the come off of the bigger islands)? I didn’t realize that was a problem. Maybe I could have the two large sides of the flat areas connected to each other, too. Interesting. Thanks for the help, btw.

It might be smoothing, where the top of the blade is trying to smooth with the sides.

This is how I meant: ​

In the first case you can keep the whole upper part with only one cut at one of the side.
Second one has more cuts

So, smoothing beyond 90 degrees is bad, then? I’ll give that a look. I don’t remember my setting for this object. I’ll have to play with this tomorrow.

ok my whole message was lost! :S
So the second one is easier to flatten… /just take one flat side from both sides…

Sure, that’s a good point. I think I can make four separate parts work, though. Thanks for the picture, btw.

Yes, so if the top of the blade and the sides are trying to smooth together then it will shade things wrong

I redid the blade and spike to bevel the top and bottom edges and changed the smoothing angle to 50 degrees. I also remarked the seems in better places. Without sharp edges marked, they didn’t have the right reflections, looking rounded and blunt instead of like blades. Even the sharp edge of the axe blade that didn’t have any bevel looked rounded by the reflections. I had to mark the outer edges of the blade and spike as sharp to make it look right. When I baked them out, they still had the same problem with dark areas. I’m guessing that it’s due to mostly being processed like flat faces instead of smooth ones, even though they are marked as smooth, and the faces that make them are numerous and not parallel. Basically, I think the engine is confused by it, especially considering that this only happened on the metal of this axe head. On my sword, everything rendered out great. Also, I didn’t like the dark coloring that static lighting gave to all of my metals. Fortunately, I don’t need to make this axe static, so it won’t be a problem. I’m just learning and thought this was odd. My current view is that Unreal’s static lighting has issues with metals that are complex. I’ll just have to make any non-moving objects that are metal as stationary instead of static. Strangely, they’ll be nice and bright instead of dark, anyway.

Here is a picture with a lightmap resolution of 1024. There is nothing weird on the sides of the blade and spike. They’re just smoothed faces like any others. Odd.

Im sorry, but why would you want to bake static lighting on an object like that? Even if its part of the background dynamic (probe) lighting will work just fine. Usually you only need to bake static lighting on objects large enough to contribute to light interaction within your scene. Smaller, and especially thin, objects are better off using probe lighting.

I was just testing out static lighting to see how it happens with my objects. Are you talking about making them “Stationary?” That is logically how I would do these, yes. My final conclusion is that this occurs when an area of faces that are mostly parallel with each other are marked with Sharp around their outer border (the blade and spike) forcing them to shade like Flat but with very small curvature. It seems to be an error in Unreal’s static lighting. I’ve tried changing the object in many variations and my only option is to use Sharp, since everything else made them look quite rounded.

If you want GI you have to bake your lighting!! …you can imitate it with dynamic lights but will never look as good or will be VERY “expensive”…

I apologize, I am used to the terminology of Frostbite.

GI is also stored in the probe data through the “volumetric lightmap samples”. What I mean is that the object should use the data stored there, like dynamic (movable) objects do, not that the lights should be dynamic. If their surface area is small and they do not really contribute much to the light interactions in the scene they don’t really need baked lightmaps.

Ok! Yes, thats what I mean. Makes sense. Thank you!