Download

Static mesh turns black when Nanite is enabled? [RESOLVED]

Anyone experience static mesh turning black when nanite is enabled? I did some troubleshooting seems this is if use material attributes is enabled, it turns black. So nanite doesn’t work with material attributes?

I use material attributes in almost all of my materials and I haven’t run into this issue yet. Do you have masked, translucent or pixel depth offset on the material? Nanite doesn’t support these either and having these on a mesh that you enable Nanite for might be causing this.

My friend and I joke that Unreal Engine 5 is a lottery. Things work for some people, and don’t work for others. Performance is great for some, terrible for others. It even seems like editor performance can change day to day.

1 Like

Yeah, was using pixel depth offset. Removed it and it works. Resolved. Thanks a lot.

I am hearing the same, certain features seem to work fine for some and doesn’t for others. I am not sure if all this comes down to differences in hardware.

pixel depth offset, your material being two sided and your material writing to a runtime virtual texture can all cause this. I believe all are intended to work properly at release/later down the line