Static Mesh and light leakage

This is my first post of a game I am building and I am having a few problems like any noob, and learning how to make a game and enjoying every minute of it. even the frustrating parts.

I’m building a house and all of the box mesh components are static. there is no sides missing can someone tell me why I am getting this light leakage and showing up on static mesh component, when there shouldn’t be. I’m using 4.6


As you can see this is the ceiling and the beams across are getting light from outside.
All components are modular and the building is put together in a blueprint so I can place multiples of the building to create a city

Do you use static or dynamic lighting? + which lights do you have in your scene? :slight_smile:

I have the sun directional light to moveable for the day night cycle. I haven’t added any other lighting at this stage just a skylight and a few sphere reflection captures. also the ceiling box isn’t thick like the walls, so could that be a problem

This is a known issue with dynamic lights :slight_smile:

-make your mesh thicker or place another mesh over it
-play around with the DynamicShadowDistance

BUMP! @seandennis: you’re no n00b, many peeps are having this and similar Dynamic Lighting issues. As fighter said it’s a known bug.

So, EPIC, when is this going to be fixed. It’s 2017 and Dynamic Lighting still broken (i’ve not tried for a few months now)?

I’m having the exact same issue and i believe that “thin” roofing is not to blame (or not entirely) and here’s why: the Devs of a game i’m also modding for have made at least one building with a single polygon(dbl sided) for the ceiling-rooftop, and although this appears to leak light at some edges inside the building in the editor, when “played” there is no leaking and no errors with lighting related to the single polygon plane of the roof and no wierd selective lighting errors such as that above (admitedly it does have a floor below it. You may also notice Normals being lit whilst the “Sun” is below the horizon - play with sun-angle and see what happens, the lighting is quite bizarre and also quite obviously broken to pieces.

Making walls and roofs/cielings stupidly thick to compensate for broken lighting is not the answer.
Telling us to simply add Blocking objects/planes to block light is also not the answer.
Fiddling with a bunch of settings that don’t actually help the situation is also not the answer.

fixing the (Dynamic) lighting system so that backface culling is ignored (pray, remove it entirely) at least on Terrain, or any “Ground-Plane” labelled/type of object, will help, i’m sure.

Please EPIC, do something, this is getting sad - I am probably going to give up with modding full-stop as UE4 has really made it difficult to go forward with my, fairly simple, project.
CryEngine has had realtime dynamic lighting for ages - i’ve used it and it is pretty good - what’s stopping you (EPIC) ?

The year is 2021, I have same issues where some of my static mesh walls bleed with light. No matter what I do. Even putting huge chunks of other SM does not help. Am I stupid to have this problem now or is it still a thing?

And orthographic just doesn’t even have shadows. Ue4 is good, but lets be real, epic has and will never ever care about this stuff.

If your bleed is caused by cascaded shadow maps (like the original post) then the solution is to make your walls thicker or use raytraced shadows.

However light can bleed in many ways, for example:

  • If you don’t place reflection captures inside your interior then you will get what looks like “light bleed” from outside, but really the problem is that it is reflecting the exterior environment because there is no reflection capture inside. This is a particularly bad problem in games that require fully dynamic lighting because the environment is heavily modifiable at runtime (such as Fortnite). DFAO is usually the most helpful solution here, as it handles specular occlusion.
  • The volumetric lightmap can also bleed through walls and floors, this will only affect movable/stationary objects (or static objects placed at runtime or using forced volumetric). The solution is the same as for cascaded shadow maps: Make thicker walls. However with default settings the walls need to be really thick, like 2+ meters. Normally this is only an issue in areas with strong lighting differences, like if you have two adjacent rooms, one that is fully lit and one that is pitch black. Everywhere else it is usually less obvious, so in general it’s only necessary to make them thicker only in areas where there is going to be an extreme lighting difference. An alternative is to use denser volumetric lightmap, at the cost of higher memory usage.
  • The regular lightmap can also “bleed” light in some sense, because movable objects such as doors cannot shadow indirect lighting so you will still get bounce light into interiors even with the door closed. The post process volume has controls for indirect light intensity to help manage this, exposure settings combined with reducing the bounce lighting intensity can also be useful here.
  • Skylight occlusion is also a common problem, when using a movable skylight the skylight can’t be shadowed. The easiest way to deal with this is to use a stationary skylight instead, this will accommodate games who employ dynamic lighting primarily for a time of day system.

At the end of the day, it is a game engine, it has to render 60+ frames every second and that means it employs solutions that have limitations and drawbacks. Every game engine has issues and developers simply design around them. Light leaking in particular is a ubiquitous problem in game engines, which is why RTX GI’s top line feature is that it avoids light leaking.