Static Lights not working

I’m guessing it may be something to do with the new Lumen system, but no static lights are working after a light build. As soon as the light build is complete, the scene just goes completely dark. If I set one of the lights to stationary, after the build those seem to work fine. Does anyone have any advice or any solutions to get static lights to work? If I change the Global Illumination in my Post Process to Screen Space, instead of Lumen, the static lights work fine.

2 Likes

Lumen Global Illumination cannot be used with Static lighting in lightmaps.

1 Like

Oh! I looked at those details but missed that critical bullet point. Makes sense now. Since the scene I’m testing needs multiple lights, and the stationary lights can only support a limited number of shadows in an area, I’ll have to test it without Lumen. When I change the GI method to Screen Space, I get a very grainy image. I’ve been trying to find some settings that may effect that, but can’t seem to find any reason.
image

If I remember correctly: You can set Indirect Light Intensity to 0 on each light and Lumen will just ignore them for the GI saving performance. So in theory you can light your scene a la UE4 and only have Lumen for your key light(s).