Static lighting not showing up for imported meshes

So I made a custom mesh in blender and imported it to Unreal. The first problem is that the mesh is way too small which is odd because I imported another mesh to blender from Unreal Engine and the size of the two meshes are the same yet imported my second custom mesh to Unreal makes it small. The other problem is the fact that the static lighting isn’t showing up on my custom mesh. Other lighting seems to show up but not static lighting. So is there something I have to do in blender to make my static lighting show up in Unreal?

To fix the size issue, make sure Blender is set to use 1 cm as its unit size. Then make sure that you apply all scaling modifiers before exporting. I also find the Blender 2.77 and later work much better than previous versions of Blender; especially for skeletal meshes.

In older versions of UE4 I am pretty sure you had to create a second UV layer in Blender before exporting. I have not had that issue since like version 4.6 or so, but you might give it a try.

You might also take a look at this and enable Generate Lightmap UV’s and see if that makes a difference:

The scaling thing isn’t working for me. What exactly do I have to do?

Starting at 1:20 this video shows how to change the scale in Blender to Metric. Then just scale your Blender objects to the right size in Blender and they will be that exact same size when they import into UE4.