Static Lighting Level Scale - setting low values creates strange shadow "stains"...

I am trying to achieve more accurate indirect lighting shadows by tweaking the static lighting level scale.
If i leave the lighting scale to the default 1, i get wavy inaccurate shadows like these:

scale 1, smoothness 0.25

When lowering the lighting scale i get weird shadows on the walls while getting more accurate indirect light shadows like here:

scale 0.1, smoothness 0.25 (and higher indirect lighting contribution from light source.) As you can see, the wall texture looks dirtier / stainy, and i have strange shadows on every static mesh in the level. Here is an example:

The lower half looks like the building was on fire, especially around the benches in the lower right.

And here’s another example:

As for the light smoothness and light quality parameters, they don’t really influence this. All tests are done with 100 bounces.
Is there a way to lower the light scale for more accurate shadows (from direct AND indirect light) without that “burnt effect” trade-off ? I dont want to compromise, since those stainy walls are a dealbreaker when doing archviz.

Also, is there another way to make indirect shadows more accurate / less smooth ?

There are some bugs in the solver with small scales, mostly with the irradiance caching. I would leave IndirectLightingScale alone, it’s really only useful for improving build times in huge levels where you don’t care about quality so much (vehicle drive-through).

The best quality from Lightmass can be achieved with high enough lightmap resolution + Production + IndirectLightingQualiity of 2 or higher (whatever you can bear) and IndirectLightingSmoothness around .7.

Also, 4.5 has a new Lightmass setting to disable lightmap compression.

“Also, 4.5 has a new Lightmass setting to disable lightmap compression”
Can you detail how this setting will affect -accurate indirect shadows- problem?
Will this result in any problems regarding performance or huge lightmap files that can crash the editor ?

It won’t affect solver quality (splotchiness, noise) but will remove block artifacts and discoloration that come from DXT5 block compression. Resulting lightmaps will be 4x larger on disk and in memory, so it’s not for everyone. But at least the option is there now.

Thanks a lot!

Cant get smooth transitions in lightning (between wall blocks ) without setting the worldscale to >.1.

note: lightmap res. are 512x512 for a 256cmx256cm wall block so out of the equation.

any other way to have proper lightning without altering the worldscale?