Download

Static Lighting and Lumen Don't Mix

Hello everyone! Like you all, I’m still learning all this brand new technology and I’m trying to light an inside scene that is fairly big in size. Although I would love to put all my light sources to movable and call it a day, this is not possible because it greatly decreases my fps.

So my question is, how can I light up an inside scene that uses all lumen lights without impacting performance? Or is there a way to make both work static and lumen together? Maybe have the light coming from outside be movable and the light inside to be static? What would be your workflow to build a scene like this and take advantage of this new Lumen technology? Thanks!

You can’t really use them together, the static lighting gets disabled when you enable Lumen. You can have multiple graphical options that the user can select that could enable Lumen at a higher setting and then use baked lighting at a lower setting.

Hey there Darthviper107, so I wonder if we can’t use lumen for big inside scenes. just for outside worlds that just really need a directional light. I really wanted to use Lumen to light my scene.

There isn’t any limitation like that, what are your system specs? If you don’t have powerful enough hardware then there’s not much that can be done, it doesn’t scale down very well, so the alternative is to not use it at all.

I have an Intel(R) Core™ I7-6800k CPU @ 3.40ghz, 3401 mhz, 6 core(s) RTX 2070

Getting poor performance off that sounds like you’ve got a ton of lights. Try turning the “affects indirect lighting” for the smaller ones off (turn it to 0). That should improve performance.

Thanks for your reply Frenetic! I’ll try this.

I would also recommend using SpotLights instead of PoinLights, at least wherever you can… PointLights are really expemnsive, especially with lumen.

2 Likes

I don’t see that setting , “affects indirect lighting” . I only see " affects translucent lighting" . Is there any loss of visual quality with any of these settings turned off or down?

Hey razmaz51, try the setting that lets you set a value for indirect lighting intensity. And set it to 0. that would be like turning it off I think. But I would assume that there will be a loss in visual quality because there won’t be any light bouncing off of things. So you have to find a way of making it work for your project. Maybe some lights have it some lights don’t.

Also, all lights have a setting under-performance called Max Draw Distance. Try playing with these values and it should help you!