Download

Static Light losing intensity after bake

Simple question: why does static light lose intensity after the bake?

prebake
prebake.jpg

post-bake
postbake.jpg

Does your light have inverse square falloff?

Your lightmap resolution looks pretty low. I think what is happening is that inverse square falloff lights have a very intense tiny bright core, and your lightmap resolution isn’t big enough to capture it. So you instead get an average of the pixels with some distance to the hotspot. Away from that spot, results look consistent.

To verify, try jacking up the lightmap resolution and rebuilding.

Another reason could be specular accuracy. Dynamic lights have real specular, but static lights all share the same fake 3 specular highlights or ‘lobes’ that just get colorized by the lightmap color. I doubt that is a big factor here, but it does show up sometimes.

I tried pushing lightmap resolution to 1024, on both Floor and Cliff. Baked shadows are still poor and look wrong:
47e7565be8197bdd1b4d2f3567f7fc3640f4c15f.jpeg

That does not look like 1024 resolution lightmaps on that floor. You can tell because of the signed distance field curves on the shadow edges. Is the bottom BSP? If so, the resolution settings for BSP are actually inverse. So you choose a smaller size to get more res.

On BSP it means “how many UV texels per lightmap texel”. it has to be different since BSP resolution is not defined by upper bound since the BSP could be enlarged independently of the setting. So a value of 1 is the highest res (I think anyways, I don’t use BSP much anymore).

I did a little test and what you said about BSP is totally correct, altough I wasn’t using BSP but basic Cube mesh.
In this case i used BSP as floor and the bake looks great
73565de07d9c23e5735b9a0b7cca7742cfdc8add.jpeg

second floor is an asset from Infinity Blades. Floor Lightmap resolution is 2048, looks bad
de13e0c3852232362256c7954b5022bdf44de2c5.jpeg

third floor is also asset from Infinity Blades. Floor Lightmap resolution is 1024, also pretty bad
36ed65f492a7fc338ea8768e21e793e3cdfe7754.jpeg

Could this be a problem with the floor UV’s?

Problem Solved.I kept changing the Lightmap Resolution inside Mesh editor where it says Min Lightmap Resolution. Setting values and Applying changes doesnt seem to actually change the Resolution so i decided to change it manually for each mesh in details panel of that mesh.
30faf8549e9dfa889b21e679701dd7215d5f37fd.jpeg

Changes are huge!

the Min resolution is only used when generating the lightmap UVs. All it does is change the amount of empty padding between UV islands.

The actual resolution setting is a bit lower, but it can be set on the static mesh settings on the asset without having to override in the world.