Start AR Session fails on Galaxy S21+

I’m trying this on a Samsung Galaxy S21+, I have the ARCore system stuff installed on my device. Other ARCore tools (like Measure) work properly.

The blueprint node “Start AR Session” is called and later when I check the status via “Get AR Session Status” it returns “Fatal Error.” I’ve tried restarting the session and it fails with “Fatal Error” each time. I need some ideas of how to get this working.

Here are the Android ADB logs:

UE4     : LogGoogleARCore: Start ARCore session requested.
UE4     : LogGoogleARCore: Pausing ARCore session.
UE4     : LogGoogleARCore: Could not stop ARCore tracking session because there is no running tracking session!
UE4     : LogGoogleARCore: Warning: Reset ARCore session due to fatal error detected.
third_party/arcore/ar/core/android/sdk/ Entering ArSession_create
third_party/arcore/ar/core/android/sdk/ ARCore Version: SDK build name: 1.18
third_party/arcore/ar/core/android/sdk/ ARCore Version: APK version code: 212010383
third_party/arcore/ar/core/android/sdk/ Dynamite load ok.
third_party/arcore/java/com/google/vr/dynamite/client/native/ Attempting to load native library arcore_c from package
DynamiteClient: Failed to load native library [,libraryName=arcore_c] from remote package:
DynamiteClient: java.lang.IllegalStateException: Library arcore_c loaded in the same classloader context as library null
DynamiteClient:        at
DynamiteClient:        at gan.A(PG:6)
DynamiteClient:        at agy.onTransact(PG:3)
DynamiteClient:        at android.os.Binder.transact(
DynamiteClient:        at
DynamiteClient:        at
DynamiteClient:        at
third_party/arcore/java/com/google/vr/dynamite/client/native/ Dynamite::LoadNativeRemoteLibrary handle=0
third_party/arcore/ar/core/android/sdk/ Dynamite failed to load remote library
third_party/arcore/ar/core/android/sdk/ LoadSymbolsDynamite returning AR_ERROR_FATAL.
third_party/arcore/ar/core/android/sdk/ LoadSymbols returning status.
UE4     : LogGoogleARCoreAPI: Error: ArSession_create returns with error: -2

I get the same error when trying to run on my Samsung Galaxy S20 phone, have you find any solution?

I had the same problem, my Settings were UE427; 29SDK; 21NDK

I kind of found a workaround for this issue . In the tick event whenever I get a Fatal Error I request for a Android Camera permission . This would start my AR session which could have been closed when I flip between applications . So I used the following BP
I could fix this issue in Blue Prints using the Request Camera permission node of Android . In the Tick event I check if I get a Fatal error I request Android camera permission

I was thinking of proposing this fix in class FGoogleARCoreDevice …What do you guys think