Download

Standalone limited to 45 fps instead of 90fps

Working on Vive.

In VRPreview we get a solid 90fps.

With standalone running with -fullscreen it is locked to 45fps. Seems like a vblank issue but I tried disabling vsync both via command and cvar.

Anyone know how to disable or fix?

Hey Jeff,

I don’t know if this is your problem but I’ve seen similar things here, and it had to do with power saving settings on the graphics card - the FPS would start at 90 but then head down to 45.

I have now ruled out card and driver settings. I can force VSync off at the driver level and I get > 90FPS on VR Preview and ~50-55fps on standalone.

It clearly does something different in standalone mode than VR preview.

Any thoughts on other things to try?

Nick from Epic helped us determine that the resolution for VR Preview was not being set correctly.

This is the Github fix:
https://github.com/EpicGames/UnrealEngine/commit/ebbb6da66e73446e03275857aa4b68394de14431