SSR quality settings

I have an architecture scene almost done with lot of stainless steel and chrome materials in it (bad idea). I need to reduce noise as much as possible and increase the quality. Do you have any settings to share?

I feel like I have everything set to maximum quality but it’s not enough yet.

SSR.quality 4
In post process volume SSR quality and intensity set to 100
I’m running this in 4k

This will be a thing in 4.9 where you can highly adjust SSR reflection settings. Just Wait for it :3

Running in 4k? Wow. I would say also increase your Screen Percentage so that there are more samples for everything, but maybe you can’t afford that.

I’m actually supersampling to 4k and displaying on my 1080p monitor…it’s basically to record movies without aliasing :slight_smile:
Interesting for 4.9…I’ll check it out!

Do you have Temporal Anti-Aliasing activated? Maybe try setting your intensity to 50 or 60 otherwise you´ll simply shut off reflection captures.

I have temporal set to max quality…

If you are up to trying to re-compile the engine then check out this persons blog.

On this page you are shown how and where you can adjust the SSR properties and what different settings will give you in terms of quality VS speed.

I’ve tried those and playing with those settings is a MUST to get good SSR without insane frame rate losses.

AFAIK you don’t need to recompile the whole engine? Just recompile the SSR shader?

I’m going to avoid playing with the shader. I’ll wait for an official solution :stuck_out_tongue: Thanks guys. Next project more wood less stainless steel!!!

Trust me, you won’t regret it. :slight_smile:

SuperSampling AA 2X With TXAA
SSR Shader Tweak (NumSteps = 16, NumRays = 8)

…Beautiful stuff.

PS. Chuck in my Dirty Bloom and… :slight_smile:
Speaking of which I need to release those textures.

You are tempting me haha! I would like a source/confirmation about what Kanizitas said about SSR control in 4.9. I looked at every single page of the preview thread and didn’t see any mention of that! :-S

It’s seriously easy as described at:

Just make sure you backup the ScreenSpaceReflections.usf shader file :slight_smile:

For any ArchiViz creator right now I would certainly recommend bumping up the SSR especially if you have 980-class cards.

The best part is by editing the usf file you can get the SSR “look” you most prefer for the most suitable frame rate.

Will leave it to you :slight_smile:

while we are trying to build archviz in UE 4.21.1, we missed reflections for only some objects, can you please help us?