Sprite debugging

I am using sprites in a topdown three-D world. they are 8-bit sprites transmitted into .png images. The problem I have is that, when using the default sprite material, a strange outline appears around my sprite. I don’t know how to fix this problem but it’s driving me nuts and It ruins the game’s aesthetic. Any solutions? Possibly a material that works better for sprites?

Hello 2 stooges -

Chances are you an issue with your Alpha Channel of your texture not correctly (read tightly) connected to your actual image, this can happen when you are using a matted Alpha Channel (by default used in Photoshop) and not an unmatted Alpha Channel.

I highly recommend watching the following video from Bill Kladis, one of Epic’s Visual Effects Artists about how to setup a correct Alpha Channel, it does reference UDK, but UE4 works in a similar fashion and most of the important information comes from Photoshop.


Thank You -

Eric Ketchum

Well, I watched that video and I couldn’t get it to work. However, I found that Unreal Engine has a default material for sprites, which is matted by default. I changed some settings around, and was wondering what I should be changing to make my sprites look normal. So far the closest and best I have gotten is translucent. Unfortunately, it still doesn’t work that well. can someone help me with the settings to find the optimal ones?