Download

Split Screen Dynamic Lights Issue

Any particular reason why in split screen with dynamic lights, unreal doesn’t process the bottom split correctly? and also why does the top split flicker?

Still image, hello?:confused: Any chance you can make a VIDEO dude? :stuck_out_tongue:
Historically, Split-Screen and Post-Process has been a problem! :mad:
Try to show switching between split-screen and single-player too! :wink:

Okay Ill make a video :wink:

Video displaying issues:
Flickering & “ghost frames” also both screens not using same lighting??

Yikes, see the problem. Is that happening on the ground blue, fence blue & white and mailbox grey materials also? So summarize this, what’s changed since this video… As there’s dynamic shadows on the ground there but no artifacts… Also, what exactly is missing from the bottom split-pane? If you add two more panes using ‘create player’, do the other two match the bottom pane or what? What engine version are you on as well?

That video I was using stationary/static lights and lightmass. It is happening pretty much everywhere and the longer i play the darker it gets.

Could it potentially a bad setting for distance fields? AO?

The bottom split doesnt seem to be using dynamic lights. The shadows are darker, and the it doesn’t look like a render of the same level.

I havent tried the 4 split, but i am going to guess it would only get worse LOL

If the earlier clip is static, what produces the character shadows on the ground in both clips? IDK, this area is out of my comfort zone. Maybe if other devs are around they can help. @Chosker [USER=“3140864”]MostHost LA[/USER] Any ideas?

Never played with split screen. Though the recent steam sale thing is making me want to…
My guess is that each split has its own camera/postprocess settings… At least, it seems like that from the video…

True, each pane has its own PP option. But the OP dealt with that type of issue before iirc, so that’s probably not the cause of this latest issue - unless they FU ofc:). Split-Screen in UE is great. Its really easy to setup and one of the areas that Epic offers a ready-made project for (past livestream). Its a great way to test out multiplayer ideas before having to deal with all of the replication bs.:cool:

Yea, the other problem i had was similar but different. Last time I was trying to get a post process effect to show up on only one pane, it was the outline fx. I still have yet to figure that one out… I am afraid to go back there LOL

The issue with my current issue is I am not using ANY PP volumes. So this is really throwing me for a curve…

where do i find the split screen project to download from that live stream?

Its one I linked to before in a past post of yours.
So just go back through some of your old posts…

I FOUND MY ISSUE!!!

I went through ALLLLL my settings, and I had “screen space global illumination” on. Unchecked flag and BOOM! Both panes show the lighting exactly!

Now I wonder why that would fudge it all up :hmm::

I would assume different settings for it on each instance?
Then again SSGI is still in beta isn’t it? Could be something that just doesn’t currently work…

Overall, it is a Screen Space effect.
like contact shadows, I’d expect them to just look wierd when you split the screen up into many screens…
The should calculate things based on the screen size of the render… so for contact shadows, the vignetting would be much more visible with a split screen.

Yea it has the (beta) notation in the flag. whew I am just glad that was it… I actually saw a 15% FPS increase as well by turning it off… i dont remember when/how/why i turned it on…

I get a 25fps drop by turning it on… so… consider your self lucky? :stuck_out_tongue:

YIKES! it is probably very gpu intensive, but does it actually make anything look better? has it been used in production already?

Not at default for now. It’s just extra cost…