Download

Spline Mesh Component replication bug

Hi,

i already postet a question in the answerhub but don´t know if this place here is even more suitable.
I´m programming a network based buildsystem like in RUST and i tried to implement the possibility to build fences. So i decided to give splines a chance because it looks good for my needs. Now my first prototype is working well with a bug. The problem/bug is that in network the clients doesn´t see the added spline mesh components but the collision works because the clients can´t run through them. The host always see all spline mesh components. The first placed Spline with its first two points is visible to all. When i´m adding new spline points to a selected spline and call my render function the spline with all its new splinepoints/spline mesh components are only shown on the host.

Here some Screens:

Call the SplineFunction from my Character:

RenderFunction:

BuildSplineElementFunction:

I already tried to seperatly set the reference “Local Current Spline Mesh” to set replicated to true, but this doesn´t help.

Now i´m really annoyed and confused about this and hope there is some one on the planet who can help me out.
Thanks for help!

Do no one have problems with splines and replication?
Can no one help me out or give a tip? :confused:

Is no one trying to work with splines at runtime?

I am seeing the same bug.