Speedtree vegetation shader issue ?

When you use 4.7, try to enable “two sided foilage” as the shading mode + connect the diffuse with subsurface -> that will probably solve the problem with the black parts :slight_smile:

e.g then you can reach such an effect as you can see here in this thread: What Are You Working On? Community Screenshots & Videos - Work in Progress - Unreal Engine Forums (the tree -> was made with the new shading mode)

It’s not working at all… there is some bug in the speedtree setup. My grass has already a twosided node… I will write today a mail to speedtree cause this is just a bad joke, how they can sell such a S****
@fighter5347 i suggest you the same, you should also complain to them…

I dont mean the two sided node, but you could try an ordinary foliage setup from the 4.7 preview -> Unreal Engine 4.7 Preview - Announcements and Releases - Unreal Engine Forums (take a look at the picture that I posted)

I dont use speedtree meshes (dont have anything to complain :D) -> I just try to give suggestions how you could solve the problem, because I dont have a speedtree mesh (so I cant try it out if they work ^^)

I saw your setup but it makes no sense for the speedtree shader… the wind and other effets are addcited to some of the nodes in the speedtree shader… But your tree looks really good!
However many thanks for your help :slight_smile: I was really excited to when i saw that speedtree is coming to UE4 but with all this issues it looks more like SpeedShi* :slight_smile:

@Adik, your grass have normal, my does not! :stuck_out_tongue: Don’t know if that’s normal. Also consider yourself lucky. The Wind for my grass is not working too… tried to export it both through the SpeedTree modeler and directly from the downloaded file, but nothing…

EDIT:

That’s the result when I’ve selected 2 side shading

Connect a constant vector with a value of 0 to specular :slight_smile: -> after that it should work (also make sure that you use the material setup that I posted)

  • apply the material to all lod’s
  • when it doesnt work, try to use a lower value at subsurface

@fighter5347 thanks! you’re everywhere ready to help! With that setup the wind should work? How do you think?

Yep, the wind should still work -> I tested it with the free trees from speedtree. Otherwise there are also some good wind shader setups which you can find here: Nature Environment in UE4 - Content Creation - Unreal Engine Forums

Ok, here is a temporary fix:

(make sure that you have a skylight with “cast shadows” disabled + a directional light)

  1. To get rid of those black shadows (normals that are pointing into the wrong direction), you have to update to the 4.7 version. There you will have to use the new shading mode:

Otherwise (when you dont want to use 4.7) use this shader setup: https://www.youtube.com/watch?v=3v_DObw9Vlk or take a look at this thread: Nature Environment in UE4 - Content Creation - Unreal Engine Forums

  1. when you dont get a wind effect, you have to go into the material - click onto the wind node (the one which is connected with the world position offset) - at wind type choose “best” (or change some other settings ^^)

Result:

http://img5.fotos-hochladen.net/uploads/highresscreensh4o7ymgfxj6.jpg

(Chance, we need a spoiler tag to hide those pictures!!! :p)

looks really good!
Did i understood you right, this shadow “issues” should be gone in V 4.7 ?

I think the issue are the normals that are pointing into the wrong direction :slight_smile: Here you can get more information about it: VertexNormal - polycount.
You can get rid of those black parts with a special material setup in the …/4.5/4.6 or with the the new shading mode in 4.7 :slight_smile:

Hi fighter, do we still need to make custom normals for our vegetation in 4.7 ?

Do you mean with the speedtrees? -> now with the new foilage shading mode you should get a good result without perfect vertex normals :slight_smile:

Not necessary with speedtree …overall, thanks for the answer!