Speedtree+UE : Black trees

Hello everyone, I come again with another question from my imported trees.
Most of them look ok, I had problems with the lighting and someone adviced me to turn off the static shadows and it worked, but for one. My biggest tree is still showing black shadowing, and when I built the lights there appears a message saying an actor is getting a previous shadow and that will cause an extreme loss of performance unless dinamic shadows is turned off. But if I turn it off too, it’ll cast no shadows at all. I’m I missing something here?
Thanks a lot!

-Could you post a screenshot?
-what happens when you change everything to the base settings + create a level with a dynamic sky and directional light? :slight_smile:
-it could be that you still have to create an ordinary UE4 foilage shader -> but therefore I will have to see a pic of your level

Hello, fighter5347. These are some screenshots, as you can seeI can’t find a setting that looks good on my level, but when I charge a new level my trees look perfect (default settings: static light, cast shadow, dinamic shadow and dinamic light on).
I’m using a lightvolume, a cube big enought to cover all my trees, but I checked it with a friend and he said it’s not that big to be the problem. I haven’t change any other parameter from the sky or anything, I only played with those above.

Again, impossible to post the images, here the links:

Just use the light setup from the template level + create a foilage shader to get the best quality:


Also make sure to make the leaves a little bit smaller to get a more realistic look. :slight_smile:
When you want to create your own light setup -> add a directional light + a skylight. Now either use static lights (you have to rebuild the light + add a lightmass importance volume + you probably have to increase the lightmap resolution) or just use dynamic ones (you get a pretty good result)

Hello again. Thank you for the quick answer, I changed a few options of the materials, made them translucent with 1 at roughtness and opacity and it worked. It’s nice to have this forum =]

Do you mean that you now use the opacity link? -> I personally wouldnt recommend you to do that, because I never got a good result with that, but could you post a pic so that I can see how it looks like? :slight_smile:

Oops, I meant subsurfaced, not traslucent. Here is the pic of the actual trees, thanks!

Yep, now it looks better. :slight_smile:

Hello Alexis MR,
can you please post a picture from your changed NEW(Speedtree)-Material, that i can see what you exactly have changed.