Speedtree for VR (2)

I’m having an issue with speedtree in VR, I would like to have the billboards keep the vertical but the object vertical not the screen vertical as in VR it’s really disturbing to see it spinning like an owl’s head.

It works fine in screen games because the player usually doesn’t tilt it’s head but in VR it’s more than natural and the effect is really disruptive.

you can sort of see the issue here:


I subscribed to the editor hoping to see an option somewhere but no luck. Is there a way to lock the billboards vertical? (I don’t mind them turning my way like a sprite, I just want them to turn in screen space along with the object they belong to.


In SpeedTree terminology, you’re dealing with “camera-facing geometry”, in this case leaves. “Billboards” refers to the impostor used as the last LOD. That may help you search the SpeedTree docs more successfully.

In order to change how the facing is done in UE4, you would need to edit the SpeedTree vertex offset code in MaterialTemplate.usf. But since you have a subscription to the Modeler, it would most likely be easier to just switch to regular mesh leaves. You do this by disabling camera-facing on the leaf generator, and switch to a better mesh for that scenario. Then your leaves won’t rotate to the camera at all.

Thank you! I tried it and while in the editor it seem there are only planes with geometry in unreal there still are sprites in the LOD0, I’ll try to convert it to the geometry, however it would be nice to have the sprites (billboards) that turn along with the world (object), not keeping vertical to the screen (the optimizations and LOD are welcome because you know… VR need all the tricks in the book to keep the framerates steady). I understand the way to do that is to change the .usf file? (HSLS code?) I’ll look into that.

What I had in the video was a desktop tree, not the hero model and that version and that is full of billboards.

Here is with the new tree:
[video]Speedtree VR billboard issue in UE4 - YouTube

On second thought maybe I didn’t select all the meshes.

Just to be sure, this is the setting you were refering to right?

Once again, it might be a workaround to make all the leaves 3d textured triangles but I would also like to have some of them camera facing like you offer them by default, only that I want them to keep vertical to the object, not the screen, when I tilt the view.

If you want to change how they work, then you’ll need to edit the shader. I can see some problems with keeping the cards vertical, though. For instance, when you went under the tree and looked up, you would see nothing but the skinny sides of polygons. But it’s up to you.

You’re in the right place for editing the leaves. You’ll want to change any leaf generator where the orientation is “camera facing” to “default” or “sky sensitive”. There may be several generators. Then save and reimport to UE4.