Download

Specular not displaying properly

Materials started to look wrong, and it took me a while to figure out exactly why, but I’ve narrowed it down to specular…

For some reason since the past few days, changing specular between 0 and 1 doesn’t seem to have much effect.
Strangely only if I put a value of -1 will I get the effect that 0 was previously getting.

I don’t know why this started happening, or how to fix it, but it’s really causing me trouble (I essentially can’t work on new materials, and it looks terrible)

I hope this picture makes clear what I’m trying to describe :
(The image in the middle with a specular value of 0 should look like the image at the bottom, and -1 should not be a value I use for specular??)

Edit : Just noting that in addition to creating a new material, if I open any existing material (that looks correct), and it recompiles the shaders, this happens and it no longer looks correct

I do see a slight change in the specular. I think it is very slight because you have maximum roughness. For an easier preview of the spec, change your roughness to 0.5 or just turn it completely smooth by setting it at 0. You should see the spec do a lot then. Try that out, if there is still an issue, then make it metallic and then you should definitely have the spec work cause you’ll see a bunch of reflections. If there’s still an issue let me know, and we’ll see about diagnosing it further.

It doesn’t make a difference changing metallic or roughness, it’s as though specular is permanently =1
Here is another example…

(these are supposed to look much more different to each other, right?)

Weird… I did a test on my end, and when I have all at 0 value, it’s pure black. Is your material set to Surface / Opaque / Default Lit?

Yes, all other values should be “normal” as default too… I didn’t personally change anything from when this wasn’t happening to when it started happening :confused:

Well the only thing different between ours is that you for some reason can change your decal response while mine is grayed out. I’d say try creating a new material again and see if it was just that material. Also, maybe launch one of the demo environments and try to create that material there, maybe it’s somehow your project that causing it. If not, then I don’t know, only think I can think of is asking you to reinstall, I don’t know what to do at this point.

Hi Krozjin,

Take a look at our information on Specular from our Content Examples Map.

This documentation link will give you some good references for what to set the specular value to for different types of materials.

I hope this helps!

Tim

Thanks, but I’m not the one having any issues with spec. OP is. I’m just trying to help troubleshoot it.

For the record, this issue began over a week ago before posting…
(I wanted to feel confident there really is a problem before posting… I’ve been using the engine without issue for many months prior to this… I know how materials work, I know how specular works. This isn’t a noob question - it seems to be an actual bug of some sort)

It appears I’m the only one having this problem, I thought maybe this has happened before to someone else or there is a known cause - I guess not (?) - so I will try some more extreme measures such as re-installing the engine etc…

Hi sneh,

I have attempted to recreate this on my end, but as of yet specular seems to be working as intended. If you are still experiencing this issue, please post this to http://answers.unrealengine.com in the bug reports section so we can track it. Thank you!

Thanks,
I’ve since figured out it has something to do with ‘Decal Response’ which was added to material settings (through Unreal Tournament)

Materials appear to work correctly if this is set to ‘none’ but for some reason this is not the default