Spawn Actor Collision Issues

I have checked other post about Spawn Collision Issues, and it would seem this is different.

I have looked into the following posts to investigate and have found no solutions.

The first post seems to be the same exact issue, but has received no response, probably because the question was vague, or because the video does not load. I would like to link these two posts to help that developer as well, but unsure how to do this.

I am running UE5.0.3
The Mannequin is vanilla, aside from an Actor Component I have added.

I am following along with this tutorial and have rechecked for accuracy.

He is using UE4, not UE5, so it could be a version specific bug, or an issue with the new UE5 Mannequin IK maybe? Not sure how to test this theory.

In the GIF I have uploaded, notice the pre-placed actor causes no issue, only the spawned instance, which leads me to believe its not a IK issue.


Any ideas or input would be greatly appreciated.

Cheers!

It is indeed a version specific bug. I switched over to UE4.27 where it worked well. The issue is that I am utilizing the UE5 Control Rig and already have other content built using UE5. Its seems this has been a bug in past versions, I wonder if Unreal is aware.

Hey @FullDeckOfFools!

I went ahead and added the “bug-report” tag to this post, so it can be aggregated with other reports and such :slight_smile: Thanks for taking the time to report this to us!

@Mind-Brain Thank you for the quick response, and for tagging this correctly. Anything you need from me: more details or my settings, just ask. I’d like to see this fixed, as spawning actors is an essential part of game design, and I would like to be able to get back to work on my spawning system. In the meantime, I guess I will work in UE4.27, and just use my work as a reference for when UE5 Spawning Collision has a solution. Thank you.

Note: Many of the posts with similar issues say that, while spawning, setting the Collision Override to “Adjust, Always Spawn” instead of “Default” is a solution, but my issue persists regardless. However, If I set it to the other two options, which do not spawn with collision, it works as expected, and the character can walk through with out the jittering effect.

These seem specific and may help with troubleshooting.

To anyone with this same issue in 5.0.3, I have tried the newest release (5.1) and it seems to be working just fine there. Unfortunately it is still a version change, but I can still utilize the new features. The compromise of game design. :sweat_smile:

Since they have taken down 5.0.3 installation from the Launcher, and replaced with 5.1, should this post be considered solved?