Source build failed with vs2013

I am fresh in C++.My colleague clone the source from github, and setup everything with README file.Also everything worked fine in his computer.I copied his entire project,then i start UE4 with my own VS2013.Always built failed,I tried some solutions ,but not work.Anyone can help me?Here are the error

  • error : Failed to produce item: F:\ue4\UnrealEngine\Engine\Binaries\Win64\UnrealHeaderTool-Core.dll F:\ue4\UnrealEngine\Engine\Intermediate\ProjectFiles\ERROR UE4
  • error MSB3073: 命令“…\Build\BatchFiles\Build.bat UE4Editor Win64 DebugGame -waitmutex”已退出,代码为 -1。 C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V120\Microsoft.MakeFile.Targets 38 5 UE4

Now,i found the main reason is Failed to produce item: F:\ue4\UnrealEngine\Engine\Binaries\Win64\UnrealHeaderTool-Core.dll.I search another solutions about the problem ,but failed always.Any documents or links?

If you are using UE4 version 4.10 + . I believe you have to use VS 2015

I am not sure whether this is an VS problem.I will try,thanks