Download

Sound Attenuation Issue

Hi folks,

I’m creating a whole interactive arch-viz in unreal and now I came to the **sound part **of my project.

This is the first time I’m working with sound and the first issue came pretty fast.

The idea is to create a TV that is gonna play some random channel and when you walk by you can hear and if you go to another room obviously you can’t hear anything.

So I created a video that works perfectly with his sound in the background in the entire project(house),
then I assigned attenuation regions to that sound and it works perfectly while I’m in VR preview but the problem starts after packaging the whole project on Oculus QUEST where that attenuation region is not working, I’m still hearing background audio with the same intensity wherever I am.

I would really appreciate it if somebody knows where this problem could begin.
Thanks a lot!

1 Like

I’ve come across the same problem recently with Quest 2. There appears to be a bug affecting media sound playback. It just ignores the media sound component I supply. Works fine on PC/VR Preview. I’m using 4.22.

Any idea how to avoid that? Maybe some additional trigger box?!

It’s a bug that needs fixing by Epic. However, you could try stripping the videos of audio and putting it in a .wav and play it like a standard audio effect. That works with 3d spatialization/attenuation on Quest just fine, it’s just media sounds that misbehave. Good luck!

Tried that already but the audio effect plays from the beginning every time i enter the Attenuation region again doesn’t follow a video…

Currently have the same problem, tried separating the audio from video and playing them at the same time but still having the same issue of audio not stopping when stop node is called.

I’m having the same problem on my Oculus Quest 2, attenuation settings work fine on PC preview but when launched to the oculus I can hear it from anywhere.

Was there ever a solution for this?