something wrong with client side logic?

I cant get anything to execute client side except on begin play. I created a completely new Blueprint based on actor even to see if it was an ark base class messing me up but it wont work. If i do a print string on the object on begin play and put it in the level i get :
Server: Hello
Client: Hello

If i run off begin play to a has authority to call an event then from that event call a multicast event to print the string i only get:
Server: Hello

If i create an on rep variable and in the on rep function i put a print string then after begin play i check for auth and then set that variable on the server i only get:
Server: Hello

If i run from begin play to auth node and only run on client to a run on server event then to a multicast event it wont even print string on the server

No matter what i do i cant get the print string on the client which means i cant set variables to replicate to client. The actor is set replicated as well…

I’d suggest you go and look at how the devs have done existing blueprint scripts on the back of various item and dino blueprints… there is a key piece of programming logic that you aren’t understanding that is specific to Unreal Editor. The only way I really learned anything was learning from dev examples.

For example, to print a message to a client’s screen… you need to call the client/server message function with a shooter controller reference. If you look at my previous posts, you’ll see a post regarding XP loss… Woeful Macabre and I were discussing this and there is a blueprint example of how to print a message to a client screen.

I will look at it again, i have a multiplayer game working fine in UE4.15.0. Maybe im doing things differently there. What im trying to do here used to work, i had missiles that fired fine. Then one update they stopped firing on the client and just hanging in the air. I will have to dive into this a bit more.

What are the chances that the variable named something like “client handles firing” is new this patch? Or perhaps test some of the logic in this thread:

i fixed my issue a completely different way, ther is enough different between new versions of ue4 and this version that i think that i expect things to work the same way and got frustrated. All good now, thanks.