Some sort of "tearing" visible when running ParticleEffects Demo with Vulkan

I’ve looked at the particle effects demo with Vulkan in 4.21, and I have not done any performance testing, I only packaged the demo in Shipping config with D3D11 and Vulkan APIs enabled, and then compared how it feels to run the resulting exe regularly, and with -vulkan.

I feel no performance difference, likely because both are running into the default VSync, GPU usage is at ~55% with both D3D11 and Vulkan. Both feel nice and responsive.

There is only 1 difference: With Vulkan, there is visible “tearing”. Very easy to reproduce. Position the camera here:

And then use the A and D button to move the camera left/right. There are “lines wandering through the image up/down”.

Is this a known issue @RCaloca ?

Using Win10, GTX 1080, 416.X driver.

Hey John, any way you can make a small video showing? I haven’t been able to repro here. Are you running fullscreen or windowed?

It’s switching to fullscreen by default, so that’s how I run it.

I just tried to record it using Shadowplay, but the issue is not visible on that recording. So I guess I’ll have to try to capture it with my phone :slight_smile:


Here, I’ve recorded a video with my phone that does show the issue:

I have recorded in 120 fps and slowed it down to 33% speed.

Quality isn’t great, but you clearly see the tearing. I know filming a 60 hz panel with a 120 fps camera in general isn’t ideal - but I can definitely not see anything like this when running it with D3D11 instead of Vulkan, that’s perfectly smooth. So it’s some issue with the rendering by Vulkan.

Got it; that’s tearing due to vsync. If you do r.vsync 2 it goes away. We’ll investigate, thanks!

Entered internal issue UE-66777 to look into.

Great! Happy to hear it wasn’t a known issue yet, so that it was actually useful for me to report :slight_smile: