Download

Some Simulated Bones Snapping to Root Bone

I’m trying to have two simulated chain-like bones on a character and I noticed that when setting the two chains to simulated in the physics asset, the left chain always simulates fine, while the right one snaps to the root bone of the skeletal mesh. I have attached pictures (in the reddit link) with a testing mesh I created to show what I’m talking about.

I tried the same thing on the Unreal mannequin (using the left and right arms) and had no issues, so my assumption is that I’m doing something wrong in Blender as this has been happening with every skeletal mesh I’ve created so far.

I’ll be more than happy to provide more information or pictures, so please ask if you think you could help because I really don’t know how to solve this at the moment.

Still haven’t been able to figure this out, does anyone know what I might be doing wrong?

To anyone who might come across a similar issue, I solved it by using Jim Kroovy’s Mr Mannequins Tools add-on for Blender.