some kind of exposure setting?


I have a simple material with a 2.5 scalar value pugged into the Emissive Colour. The material is applied to a sphere and there’s a nice glow effect around it UNTIL I approach. Both in the viewport and during Play, the glow disappears close up and also negates the lighting around the sphere. Objects close to the sphere become too dark to see. I’m not using a Post Processing Volume. This happens with a raw material and sphere. If I look away from the sphere, the lighting returns to normal, even close up.

What setting do I need to change this behaviour? Is it some kind of exposure setting somewhere? I can’t find anything in the sphere’s lighting settings.

Try adding a post process volume and activating auto exposure. You can then set the Min Brightness and Max Brightness to the same value so that it’s always constant.

Thanks. That works.

What is the functionality that’s causing this in the first place? I would have thought it would be less expensive to have it off by default.
Any way to disable it?

Don’t worry, I got it. I have to turn off Auto Exposure in the project settings.

Ah so that’s where it comes from. Thanks for sharing.