Some HLODs turn black as their lightmap rather then have any lighting

Some HLODs turn black as their lightmap rather then have any lighting. Any ideas ?

For something like this, it would be helpful to see the lightmap for the proxy mesh that is generated. Likely has bad UVs from overlapping geometry that didn’t have a good UV layout conducive to the auto-generated method before hand.

If it’s only happening with custom content try correcting the UVs and then regenerating the proxy mesh.

the geometry is a bunch of flat walls… not much that can be done there in terms of uv layout. Its pretty basic 1 to 1 kinda thing. I will look up the mesh in a sec to see if unreal broke the uvs.

Hey Tim,

After looking at the created meshes by unreal… it seems it created 2 extra uv sets for a total of 3 uv sets… uvset 0 ,1 ,2… uv set 1 looks like the appropriate one to use, but uv set 2 was the one that was using which had a lot of overlapping geometry. Any idea? i mean i can manually set it to 1, but its kind of a pain if i have to do that every time.

its actually a very large hlod with like 40 models… all sorts of stuff in there i guess… I didnt expect it to be that large, but still that shouldnt matter… its kind of the point of the system… hell the mesh has like 40 materials on it, but its just a big combo of stuff. And as i said… uv 1 looks correct for a light map as u would it expect it to look… its just using uv 2 by default in the generated mesh settings.

Also already checked the HLOD settings… target lightmap channel is already set to 1 in there… so it should not be using 2 by default… Like 3 different levels of HLOD all with own distance and size settings.

Are these walls just a single plane or boxed geometry? I can give it a test with the template floor or the editor plane since these are set up how I would expect for normal UV layouts. I’m curious if it’s having issues knowing whether to create the UV when one is already there so it makes the third one and mistakenly assigns that one. Seems wonky if that’s case, though.

Thanks for the quick response!

Hey Tim, Some more info… im messing around with my project in 4.13 now and im looking at some of these HLODs… for instance… 1 only has UV 0… which is obviously the textured assets uvs and they all overlap since they are combined… it never generated a uv 1 for a lightmap even though the settings are telling it to do that…

Another group created a uvset 0, 1 ,2 ,3 for some reason… and uses uvset 3… The uv set looks fine, but the lighting looks black regaurdless… doesnt make much sense…

This HLOD “system” has had problems since day 1. like 50 freakn problems …


I’ve submitted the ticket for this one to be investigated. It looks like a regression in behavior between 4.12.5 and 4.13. 4.12 would correctly assign the target lightmap coordinate where as now it’s not, and also another issue was if I already had a setup UV for the lightmap there would only be a single UV when I merged the two.

Eitherway, the issue can be tracked here if you need it: Unreal Engine Issues and Bug Tracker (UE-35639)

Thanks for reporting the issue.


This appears to have regressed again in 4.14 (happening to me in 4.14.3), all HLOD meshes come out with the lightmap index set to 0.


When I check this using the repro steps I had listed in 4.14.3 and in our latest 4.15 preview everything works as I would expect and the correct Lightmap UV is assigned. If you’re having an issue and you have steps that can reliably reproduce it, please post a new ticket in Bug Reports and we’ll have a look.

You may also want to try 4.15 when that releases later this week to see if the issue still persists for you.