Download

Some direction...

Ohh! Thats something I have never done on other packages. I will proceed with this method to experiment.

I decided to look into stem roller and used it on the whole building as 1 unit and the roof and floor. But doing more reading I realized I had the units wrong. I never selected CM. SO I did and it improved the room but … look at these 2 screen shots. If I am closer to the problem area of light leak… its fine. But if I take a step back… it comes into the scene.82891786cf4ac9a6e1baadc70e2b3659805f26c3.jpeg53bd9492b6ca1d2112bf7b69fba688fc760e0494.jpeg

To boot, the top light leak didn’t get effected at all. I think I will try the separating the walls and see what happens.

Did you make a type? You said to put it to channel 2. But i noticed the unreal editor has a channel 0 and channel 1. Does it mattet or its fine?

Forget it… nust read on it. Its channel 2 like you said.

wow… this a lot of work just to get a room to not bleed. If anyone has a guide how to do the spacing in the UVW editor where people snap the verts to the squares, please post it. Im lost there. But I made progress… i managed to get some of the bleeding out with the uv channel and steam roll.

It would have little to do with spacing if your entire building is one mesh, there’s just not enough room on the UVW space for all the information you’re trying to bake. Read through this:
http://www.worldofleveldesign.com/categories/udk/udk-lightmaps-01-basics-and-important-principles-for-creating-using-lightmaps.php
It’ll help you understand your problem and will allow you to easily see whats going wrong. It’s a simple problem with an easy solution.

Ok… will read that. THXS!

No problem, I used to struggle wrapping my head around UVWs as well, that article made it click for me. Feel free to ask if you have any questions!

Hi Syrom, sorry for late reply but I see you got an answer. I tested out Steamroller myself which DMHokie suggested, and thats a big time saver script. Lovely suggestion DMHokie. And as James is saying. This phase in your learning is a lot of back and forth until concepts and workflows get internalized. It’s like that for most of us. But It’ll all go much quicker when it starts to slowly click.

One thing, on import have you made sure to turn off “Generate Lightmap UVs”? You need to expand some options on the import dialogue to see the option.
9cb0b01c0c7ba0abbf9fa96d0acbad727035fd43.jpeg

Hey James, I checked out the vid. Its Maya though… never used it. Strictly 3dsmax. But its a good watch to get it to click for me. Ill watch it over and over to figure it out. thanks again… i will continue.

Yup… i did . I think my issue is the UVW part still. I am getting different results everytime I redo everything so i think I am on the right path. Im still searching for a guide to let me know how people do the snap to verts thing on the uvw editor. I am sure i will find it with time. thxs for the advice!

I did a simple test. Created a cube with 1 opening. and use steam roller script. exported it. unchecked “create uv light maps”. ANd this is what I got. SO there is something else I am doing wrong. I will read and watch more vids since it also has the leaks and its 1 whole cube with no seams.35c17a04cd41eb469ca245710dda51b083bfe12b.jpeg

And here is the test box. I flatten it with steam rooller. Made sure its in channel 2. unchecked "create lightmap: on unreal. Increased the light resolution from 64 to 512. Clicked on Double SIded. And running unreal at EPIC. ANd still get light leak inside. LOL! 13b2b7284ed86fe0cfc2fa019f571ee28b695082.png

A couple of things you can try:

  • When you collapse your mesh to an edible poly, run reset x-form
  • You do have a basic material on it in ue4? If not, drop the basic wall or something like that on it.
  • Do you only have the basic lighting setup now? In other words, just the exterior light source? If so, you can drop a skylight into the scene, and even add a reflection capture and a point light with low values inside the room.
  • What UVW vert snap thing are you thinking about?

c62ce5d796c878cf226c638efbe888f39d2c1c4b.png

Here is the UVW for it. Set to channel 2 and all. What is wrong with it? Seems like I am following every step. I got this manually by adding a UWV modifier. Selected channel 2. Flatten it. And thats it really. Am I suppose to click on something else inside the uvw editor on max?

Your UVs are good. Have you unwrapped channel 1 as well? In case that confused you. The channel 1 is for you textures. The channel 2 is for the lightmap. I am guessing you got that, but just to be sure. Just make sure to collapse the mesh before export you should be good. But actually, as I am looking at your image. I dont think there’s anything wrong with it. Its just that you don’t have any lights in the scene. I think thats your issue at this stage, so move on to experiment a little with lights and see what that gets you.

I will run xform.

I did apply the wall mat.

I selected “New Level” and selected “Default”.

I have seen vids under this very topic where people recommend selected “Snap to verts” so the uvw is evenly put on the square grids but I dont think thats necessary since they are even already by flattening the primitive box.

hmm… glad to hear that. I will experiment with the lights.

Also… I have not unwrapped channel 1. I just unwrapped channel 2 since its a lightmap. But that could be the issue? I will experiment.

Ahhhhh… Added a skylight like you said Kurt. Seems like this is PROGRESS!