Some certain places on landscapes are very dark if Skylight cast shadows

If I set by the sky light cast shadows = on I get on some few certain places very dark shadows. Some foliage is very dark too in the shadows of the very dark mountain. I don’t no why, all other places are correct.

I tried:
-setting static lighting resolution on the landscape to 10
-smoothing the landscale
-change material landscape
-deleting all the painting on the landscape
-deleteing the cell and his neigbour cells (where the dark shadows are) on the landscape and add new cells into the holes

this brown color is very strange, I don’t get it away by changing material

if I set the skylight to moveable the dark shadows are gone