Download

Some black area when I build lightmap

Hi guys.

I’m new UE4,use UE4 for Archviz , I had problem when I build LightMap into my scene,Which basic setup lighting for interior with LightmassImportanceVolume , PostProcessVolume,Skylight DirectionalLight as sun , to bake LightMap,The result, too many black area on the wall, weird static mesh,some lighting incorrectly,I had increased lightMap resolution higher to fix problem but it still there, change space size UV channel 2 equal 0.04 to get more space bleeding pixels,check Lightmap UV are overlapping,but the problem not fixed, I spent 3 days for test this,find the same thing on forum,but I couldn’t good result

On the 1st picture it shows UV channel 0. The channel 0 is the texture UV. The channel 1 should be the lightmap UV. You need 2 different sets of uv for each mesh. Do you have a 2nd uv channel on your chair? If yes you can change it, if not you’ll need to return to your 3d modeling software and make one or ask unreal to generate one for you on import.

Update : ok it seems your uv lightmap coordinate is set to 1. Can you post a screen of uv channel 1 instead of 0, so we can see if it’s good?
Are your walls made of meshes or unreal brushes and what are the lightmap resolution for walls?

  • Here some UV channel 0 and Channel 1 for static mesh in Unreal,some object I use the same UV for two channel,and increase Light Map resolution to 2048 px,
    3abc2d1da33bc6be913bcf993e4a5c6eb1f8cf5b.jpeg
    c24cc188a91c1f163b392801cd5f8eb747c86353.jpeg
    659487a7e4f69b4673403b40b97246ba73593798.jpeg
    Capture11.JPG

  • The wall I made from 3ds max and export fbx file to unreal which 2 channel , channel 1 for seamless diffuse texture, channel 2 for light map,
    ffca02d069e33d068d8f25bcc5bcc9f200534b44.jpeg

  • My world settings
    Capture22.JPG

  • The lighting I set to Static to all lights in My Scene, because no moving objects