Download

Some areas not getting dynamic shadow?

I have a ‘moveable’ directional light casting dynamic shadows and everything works great aside from a few spots. When I move through them, parts for some reason seem to be fully lit. My ground is made up of quads only, I tried shrinking them by adding more edges to my mesh without much difference (the spots just moved/split up).

I have absolutely no idea what could be wrong and would appreciate any tips.

Here’s a video of it in actionThe ground should preferably not be lighting up like that randomly.

Here are my light settings.

I have the quality settings set to epic in the editor, this thing is also happening when I build the project.

I’ve tried splitting my whole level into many smaller meshes instead of a single one, thinking it had something to do with a too large mesh. But no luck. These things are still popping up randomly along the way.

edit: changing the shading model in the material fixed it. Seems like it was an issue with the sss?