Download

[Solved] Weird Shadow on static mesh

Hello there,

I search on internet since hours now, and face an issue many encounter, but… no proper solution worked right know.

As you can see on this picture, i’ve got hards black weird seams.
I’m using blender + Substance.
Normals are baked with substance.

Please notice, it’s my first mesh attempte.
I’ve tried pretty much everything : export FBX to unreal with normal, with tengeant, face, edge for smoothing, Mikktspace as import in unreal, etc etc… nothing work atm.

In blender i use auto-smooth + mark seams edge.

Thanks if anyone have any idea about this !

In Blender :

In Substance :

Are you talking about the seams or the way the shadow looks?

I guess, the way shadow look.
I mean, it’s follow the edge of the low poly model w/o smoothing, no ?

The way the shadow looks on the object in engine depends on the lightmap quality - the actual quality of how the UVs are unwrapped - and the lightmap resolution; which you set up on the mesh in engine.

Personally I do not rely on unreal to bake you a good UV for lighgmaps.

Set up a texture at 256. Enable snapping to pixels, unwrap, and manually place/adjust the islands of the object.

In engine set the lightmap resolution to 256 - more than enough for a barrel - and make sure the correct UV channel is used as the lighmap / uncheck generate lightmap option too.

That should have the shadows looking OK.

The seam is another story. You have to properly set up all the material layers - the seam is also visible top left of the substance screenshot.

Hum, unfortunally i did everything (and i hope i did everything well) and nothing change :

Here the lightmap, and configuration in UE :

I set 1024 as size, i know it’s oversized, it’s just for the text.

Blender :

image

image

A bit lost honeslty.

Update : Got it !

This is contact shadow.
Without contact shadow, mesh look fine :

A good thing i miss to precise, light is dynamic on the scene.

So now, i need to figure how i can fix my contact shadow.

Leave them off. It’s a Screenspace effect that really doesn’t do much at all except screw up scene lighting.

As far as UV.
The one labeled UvMap is far better for light.
You want the cylinder to only have 1 seam for the lightmap.

But since light is dynamic I guess it doesn’t matter…

1 Like

Yeah, the second uv was a auto smart uv just for testing cause i want to test, before doing thing properly.

The fact is i’m using contact shadow for those tiny shadow on the ground.

On :


Off :

I guess i can remove them, but would be better if i can keep them.
I just also don’t understand why on my model it’s ■■■■■■ up, and why this is perfectly fine with other modele with less triangles.

By the way, huge thanks for the help and your time !

Take screenshots of the same camera view (put a camera in viewport. Pilot it to screenshot while running in PIE.
That way you can see the actual difference that contact shadows are making.

As far as to why it looks as it does on the barrel, It’s based on the model topology.
And/or you could possibly have a second piece of mesh inside the barrel.

Ps:
Light UVs with smart unwrap aren’t that good. The engine actually does a better job than blender 90% of the time.
Most of the issues when baking are due to the UV not being aligned to the pixels…

1 Like