Download

[SOLVED] VR problem in 4.18 version

Hi,

I converted my project from 4.16 to 4.18 version, and the problem of VRPawn is appeared. The camera is get below the floor when I start the playing. I tried to adjust the camera to the proper height but it didn’t solve my problem. I created the new project with VR features, I tried the VR in it and everything is okay.

Greetings,
Janos Csaszar

Hi, few things to check:

  • The settings for your Tracking Origin (Floor Level or Eye Level)
  • The hierarchy of components in your VRPawn (root → VR Origin Scene Component → Camera)
  • The initial Z offset of the camera respect to the VR Origin
  • The placement of the VRPawn in the scene (direct vs. Player Start) and its initial position (e.g. flush to the floor)

Cheers,
Marco.

Hi again, Marco,

I’ve checked these things and I assume they’re correct. The VRPawn’s blueprint is default and I haven’t changed the parameters. I’ll show you more photos if you require.

Cheers,
Janos

How did you set your Tracking Origin? Floor Level or Eye Level?

Floor Level. If you mean the Blueprint settings in the Event Graph.

I mean with the Set Tracking Origin blueprint function. What is the parent class of your VRPawn? Are you using any plugins for it?

Alright. The parent class of VRPawn is Pawn and I don’t use any plugins for it, it is default.

Ok, then it should work as it is supposed. Maybe you can try to create a new one from scratch and see if that one behaves as expected?

Yes, in the new VR project from scratch this one works.

I mean a brand new VR Pawn in the current level, with just the Enable HMD and Set Tracking Origin to Floor Level. Structure: Root Scene Component → VR Origin (Scene Component) → VR Camera. Place it in the level, flush to the floor, and possess it.

my guess its the renaming of oculus in blueprint (4.17) issue here. see more VR player height not working in 4.17 - UE4 AnswerHub

That’s why the very first question I asked is how he was setting the Tracking Origin. But apparently that is OK and the problem is somewhere else. Or?

Sorry, my bad. Thank you guys for your help! In the blueprint editor I just added a new pin called “OculusHMD” in the Switch on Name node and I tied the output to the same node as “OculusRift”. However, I found this site earlier about blueprint 4.17 issue, that time I changed the name, and this way didn’t work for me. Thank you again! :slight_smile:

https://imgflip.com/s/meme/Captain-Picard-Facepalm.jpg