Download

[SOLVED] VR Preview option blacked out

Trying to create a simple VR game. Here’s what I did:
Run UnrealEngine 4.20 (Administer and regular)
New Project
I’ve tried VR Project, and blank, with Mobile/tablet + 2D/3D scalable, and Computer/PC with Maximum Quality.
With the Computer/PC it crashes the game + editor if I try to run the game in VR (I have Oculus Rift)
With the Mobile/Tablet the first time I tried it just crashed me, now the option is just blacked out.

Now with non admin + PC/Computer + VR Template, the VR Isn’t blacked out but it still crashes UE4 and the editor
Enabled Oculus Beta still nothing

I just had to update my video drivers.

Hello,
when you have your Oculus rift are you having oculus home and experience your home without problems?
Regarding UE4 did you tried the VR template BP ?

Yes my home is problemless, same with UE4 games, Steam games, etc…
BP? I don’t know what that means, but I tried all combinations of options with VR template.

Now the preview button isn’t greyed out, but VR preview still crashes.

I’m going to bump as this has gotten 0 responses.

You may have plugins conflict. Make sure that in the VR section of the plugins only the Oculus VR one is active. Then restart everything and try again.

SteamVR was enabled, but after disabling it UE4 + the game still crashes. Thanks for the idea though.

Do you get any crash log? There is a link to them from the crash window. They usually help understand what caused the crash. You can share them here.

Ok there is something else.
Try a new project with VR template WITHOUT the default Starter content.
( By BP I mean not C++)

Skip the VR template and go for an empty project, add a Pawn blueprint, add a camera to the blueprint (if there isn’t one), in the camera details set to use HMD rotation, in the gamemode set the pawn to be the default pawn. Make sure there’s something in the scene to look at so it’s not just black space.

Had a look at the log file. Looks like a video drivers issue to me. The crash seems to happen as soon as the render target for the Oculus is allocated. Did you try to update your video drivers?

I’ve been wanting to update them, looks like the perfect excuse. Thanks for the help.

Just a bit of googling, and everything is good :slight_smile:
Drivers are updated! Its working!