Download

[Solved][UE 4.20.3] Volumetric Lightmap problem: black box areas on movable actors

Is anyone else experiencing this kind of problem?

After building lightmaps, some indirectly lit areas are completely black/shadowed for dynamic objects. I know it is related to the Volumetric Lightmap (VLM) because if I toggle it on Show > Lighting Features, the problem is toggled as well.

It’s not a lack of lightmap samples because then it would be a smooth transition, and there are samples in these areas and they aren’t black. Instead, it’s a sharp transition into black. It affects all movable/skeletal meshes that pass through it.

Trying to solve it myself, I’ve already ruled out some things:

  • According to the Output Log, I set it up to much more brick memory than needed, so that’s not the problem.
  • It doesn’t have to do with meshes or something I’ve placed on the map because if I change the VLM Detail Cell Size, the “black box” areas appear in different random places.
  • There are VLM samples in these areas and they are not black.
  • I’ve already tried cleaning the Swarm cache before a light build.
  • The level is built with sub-levels, but none are streamable and I’ve already tested with everything on the same level, but the issue persisted anyway.

Build quality is set to Production. Everything is configured with pretty high quality, and still I’m having this problem on random places. The central gate is a skeletal mesh and you can notice the top part is black, like the movable meshes near it. And this is not the only area in the map like this. Other areas, near or far from this one, also have this problem.

Is this a bug? Some setting I don’t know about? I’m tired of trying to solve it alone and found nothing like this on the forums nor Answerhub. Unfortunately I can not send the project to anyone because of contract. Only for Epic staff. So, if anyone had this problem and solved it, please help!

The problem was RectLights with zero width/height. If any of those are 0, the problem appears.
Now, “why the hell would you have zero sized RectLights, Rodrigo?” Because I created a Blueprint with light meshes that could represent spots, rects and cylindrical lamps. But DestroyComponent was not working for the lights not supposed to be active and AddComponent was also giving me problems. So what I did was to leave all lights in the Blueprint and “disable” them by setting intensity, radius and everything to zero. But it took me a month to realize that those problems were happening because of it! A MONTH!! I did a lot of testing and setting both width/height to at least 0.1 solves the problem.