[SOLVED] Touch Controls doesn't work

I’m new in VR. I would like to convert my project containing basic keyboard input (with FPS and Player blueprints) to be VR ready so I’ve imported VR functions. However the Touch Controls doesn’t work. The mannequin arms are visible and I can move them but I cannot use the buttons (for example I cannot teleport and move objects) but in the VR editor view I can use them completely. Nevertheless I created the new project with VR function and the Touch Controls works. What should I do, which option can solve my issue or how can I turn off the irrelevant blueprints if they cause the problem?
Thank you for your help in advantage!

Probably you didn’t carry over the input mapping for the motion controllers from the VR template. In the VR template project, go to project settings → Input, export the input and re-import them to your VR enabled project.

Thank you for your help, but my problem not quite resolved yet. From now on I can use the motion controllers in Motion Controller Map in my current project, but not in my scene or level. I assume the problem is related to Player Start or GameMode or something. I cannot play the level with MotionControllerPawn, but just with a wrong (perspective) camera.

It is possible that you are not possessing your VR Pawn properly. It is hard to tell without seeing any screenshots of your configuration/level.

There are basically two ways to do properly possess your VR Pawn:

  1. Don’t use Player Start and place instead your VR Pawn in the level directly. Within the properties of your VR Pawn, select Autoposses: Player 0. This is what the standard VR Template does.
  2. Place a Player Start in the level, create your own GameMode and assign your VR Pawn class as Default Pawn to the GameMode. As an alternative you can override the settings of the default GameMode in the World Settings.

Don’t do both at the same time or you may end up with two instances of your VR Pawn (e.g. two pairs of hands…)

Hope this helps.


My problem is solved, thank you very much! The solution is always simple for the big issues. :slight_smile:

Great! Can you please edit the title of this thread and put a [SOLVED] in front of it? It will help others in the future to find this solution.

As good as vr_marco’s solution is I found that when using that blueprint for locomotion I ended up not being able to traverse up slopes, hills, and stairs. After like 10 minutes I found this video: . If that solution above doesn’t work just try this one, you don’t travel towards the yaw of your HMD just from that tutorial but that’s easily fixable with just a few more nodes.