Download

[SOLVED] Failed to find package lldb;3.1 when trying to install Android for 4.25

So I Uninstalled NVPACK and deleted everything to start a fresh Android Install
Downloaded Android Studio 3.5.3 following this guide:

https://www.unrealengine.com/en-US/t…al-engine-4-25

(I’m on windows 10, also instaled the 64bit version, don’t know if that’s relevant)

Installed and did every step of the guide, but when I try to run SetupAndroid.bat (as administrator) from 4.25/Engine/Extras/Android the script in cmd says:

Warning: Failed to find package lldb;3.1
Update failed. Please check the Android Studio install. updates…

And it stops there.

Any… suggestions on troubleshooting this are greatly appreciated.

2 Likes

I bypassed the install following this solution posted here by DarknessFX

The workaround provided by @Juanmilanese and @DarknessFX here is the correct one, and we’ve added a note about this in the new NDK 21b setup doc on the Unreal docs site. This issue will be fixed in 4.25.1.

@VictorLerp - I advise stickying this page for any other people looking for the solution to this problem, as it is likely to reoccur until 4.25.1.

It’s stuck now, let’s hope .1 dissolves the glue.

I am getting this error while trying to setup ndk

Yeah, I’m getting that license agreement error as well when trying to run the .bat

Ohhhh thank god someone found a solution for this, I was going crazy trying everything I could think of to get it to work for the last few days! I tried that and it works! :smiley: