Announcement

Collapse
No announcement yet.

Fails to install Android SDK, NDK, etc properly

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Fails to install Android SDK, NDK, etc properly

    I am trying to runa test cardboard vr app on android and started by following this guide until I got to the part where I had to add the SDK, NDK paths, at which point I realized I had to setup all of those. So, I began following this guide to install Studio and all that, but it fails at the part where you run androidsetup.bat. It gets to sdkmanager.bat, then says something about not finding something and downloading, then a bar starts across, gets to about 6%, and then the bar disappears and says it failed to find package 11db;3.1, and tells me to check the android studio install, as seen in the attached picture here.

    Click image for larger version

Name:	Screenshot-5.png
Views:	2395
Size:	20.3 KB
ID:	1757110

    I have done some decent troubleshooting. At first I figured it was because I also had some old install of AndroidStudio from some ROM work that I uninstalled but might have had some lingering files, so I tried to fully remove Android Studio, the SDK, and all other related files, as well as updating Java before reinstalling studio and running it again. It had the same behavior as above. I redid the entire process several times with the same result. To ensure it wasn't something to do with my specific machine, I installed UE 4.25.0 on a different machine that had no other versions of UE, and had never had any Android related files whatsoever. It also failed at this step in the exact same way, so this issue doesn't seem to be device specific.

    Is there something glaring I am missing? And if not, can anyone else confirm this behavior?

    Thanks in advance for any help you can provide.

    #2
    I am also getting the same issue on the Mac as well. I also did a clean Mac OS and UE4.25 install and still get the same error.

    Comment


      #3
      I am also having the same issue, I think it may be something to do with my account not having admin permissions. I'll report back if i find a solution.

      Comment


        #4
        Originally posted by Monsair View Post
        I am trying to runa test cardboard vr app on android and started by following this guide until I got to the part where I had to add the SDK, NDK paths, at which point I realized I had to setup all of those. So, I began following this guide to install Studio and all that, but it fails at the part where you run androidsetup.bat. It gets to sdkmanager.bat, then says something about not finding something and downloading, then a bar starts across, gets to about 6%, and then the bar disappears and says it failed to find package 11db;3.1, and tells me to check the android studio install, as seen in the attached picture here.

        Click image for larger version

Name:	Screenshot-5.png
Views:	2395
Size:	20.3 KB
ID:	1757110

        I have done some decent troubleshooting. At first I figured it was because I also had some old install of AndroidStudio from some ROM work that I uninstalled but might have had some lingering files, so I tried to fully remove Android Studio, the SDK, and all other related files, as well as updating Java before reinstalling studio and running it again. It had the same behavior as above. I redid the entire process several times with the same result. To ensure it wasn't something to do with my specific machine, I installed UE 4.25.0 on a different machine that had no other versions of UE, and had never had any Android related files whatsoever. It also failed at this step in the exact same way, so this issue doesn't seem to be device specific.

        Is there something glaring I am missing? And if not, can anyone else confirm this behavior?

        Thanks in advance for any help you can provide.
        having the same problem

        Comment


          #5
          I had the same error. I've got able to bypass the problem by editing the SetupAndroid.bat, line 75, and removing lld;3.1 from the install list:
          ==
          call "%SDKMANAGER%" "platform-tools" "platforms;android-28" "build-tools;28.0.3" "cmake;3.10.2.4988404" "ndk;21.1.6352462"

          Comment


            #6
            Originally posted by DarknessFX View Post
            I had the same error. I've got able to bypass the problem by editing the SetupAndroid.bat, line 75, and removing lld;3.1 from the install list:
            ==
            call "%SDKMANAGER%" "platform-tools" "platforms;android-28" "build-tools;28.0.3" "cmake;3.10.2.4988404" "ndk;21.1.6352462"
            Thank you! worked for me

            Comment


              #7
              Same problem and same solution. Thanks!
              In addition: I had to create an empty "repositories.cfg" file in my /.android/ user configuration to bypass another check.
              Some improvements are needed to the Android dependencies installation.

              Comment


                #8
                Hello Guys, thanks its worked for me.

                Special thanks xadamxful

                Best regards

                Comment


                  #9
                  Same and Same.
                  Also needed empty "repositories.cfg" file.

                  Proper thanks! DarknessFX, F3NR1S

                  Comment


                    #10
                    Originally posted by DarknessFX View Post
                    I had the same error. I've got able to bypass the problem by editing the SetupAndroid.bat, line 75, and removing lld;3.1 from the install list:
                    ==
                    call "%SDKMANAGER%" "platform-tools" "platforms;android-28" "build-tools;28.0.3" "cmake;3.10.2.4988404" "ndk;21.1.6352462"
                    It works, but we still need LLDB for debugging.

                    Comment


                      #11
                      Originally posted by DarknessFX View Post
                      I had the same error. I've got able to bypass the problem by editing the SetupAndroid.bat, line 75, and removing lld;3.1 from the install list:
                      ==
                      call "%SDKMANAGER%" "platform-tools" "platforms;android-28" "build-tools;28.0.3" "cmake;3.10.2.4988404" "ndk;21.1.6352462"
                      Thank you! <3
                      UE4 Marketplace Contents

                      Comment


                        #12
                        Originally posted by DarknessFX View Post
                        I had the same error. I've got able to bypass the problem by editing the SetupAndroid.bat, line 75, and removing lld;3.1 from the install list:
                        ==
                        call "%SDKMANAGER%" "platform-tools" "platforms;android-28" "build-tools;28.0.3" "cmake;3.10.2.4988404" "ndk;21.1.6352462"
                        It works to me. Thanks.

                        Comment


                          #13
                          Originally posted by DarknessFX View Post
                          I had the same error. I've got able to bypass the problem by editing the SetupAndroid.bat, line 75, and removing lld;3.1 from the install list:
                          ==
                          call "%SDKMANAGER%" "platform-tools" "platforms;android-28" "build-tools;28.0.3" "cmake;3.10.2.4988404" "ndk;21.1.6352462"
                          i did this but after i got this error :
                          ---------------------------------------
                          Accept? (y/N): y
                          [=======================================] 100% Unzipping... android-ndk-r21b/sha
                          The system cannot find the path specified.
                          Success!
                          ERROR: Invalid syntax. Default option is not allowed more than '2' time(s).
                          Type "SETX /?" for usage.
                          ERROR: Invalid syntax. Default option is not allowed more than '2' time(s).
                          Type "SETX /?" for usage.
                          Update failed. Did you accept the license agreement?
                          Press any key to continue . . .


                          Comment


                            #14
                            Originally posted by Monsair View Post
                            I am trying to runa test cardboard vr app on android and started by following this guide until I got to the part where I had to add the SDK, NDK paths, at which point I realized I had to setup all of those. So, I began following this guide to install Studio and all that, but it fails at the part where you run androidsetup.bat. It gets to sdkmanager.bat, then says something about not finding something and downloading, then a bar starts across, gets to about 6%, and then the bar disappears and says it failed to find package 11db;3.1, and tells me to check the android studio install, as seen in the attached picture here.

                            Click image for larger version

Name:	Screenshot-5.png
Views:	2395
Size:	20.3 KB
ID:	1757110

                            I have done some decent troubleshooting. At first I figured it was because I also had some old install of AndroidStudio from some ROM work that I uninstalled but might have had some lingering files, so I tried to fully remove Android Studio, the SDK, and all other related files, as well as updating Java before reinstalling studio and running it again. It had the same behavior as above. I redid the entire process several times with the same result. To ensure it wasn't something to do with my specific machine, I installed UE 4.25.0 on a different machine that had no other versions of UE, and had never had any Android related files whatsoever. It also failed at this step in the exact same way, so this issue doesn't seem to be device specific.

                            Is there something glaring I am missing? And if not, can anyone else confirm this behavior?

                            Thanks in advance for any help you can provide.
                            Ia have the same problem

                            Comment


                              #15
                              Originally posted by Cody10 View Post

                              i did this but after i got this error :
                              ---------------------------------------
                              Accept? (y/N): y
                              [=======================================] 100% Unzipping... android-ndk-r21b/sha
                              The system cannot find the path specified.
                              Success!
                              ERROR: Invalid syntax. Default option is not allowed more than '2' time(s).
                              Type "SETX /?" for usage.
                              ERROR: Invalid syntax. Default option is not allowed more than '2' time(s).
                              Type "SETX /?" for usage.
                              Update failed. Did you accept the license agreement?
                              Press any key to continue . . .

                              I'm getting the same error, and I haven't been able to find a solution yet :s

                              Comment

                              Working...
                              X