SOLVED: Exponential Height Fog not rendering in Sequencer

Hey guys!
I ran across this issue a few times. When I hit “play” in Sequencer or I try to render the sequence (Sequencer or Movie Render Queue) the Exponential Height Fog disappears along with all volumetrics.

Here’s how it looks in the viewport:

And that’s what rendering - no atmosphere, no particle system (with volume material) at the center:

For solution - look in the next post

That’s solved! For all the newbies like myself who came across this issue.
When you hit play in the Sequencer your viewport activates Game View mode, which hides all the sprites and controls, but is also adjustable.

To fix the issue:

  1. Activate your GameView mode by pressing “G” in the viewport or by selecting “Game View” from the top left corner menu of your viewport. If your volumetrics disappear, you’ve just found the culprit!

  2. While in Game View, go to the “SHOW” menu. Most likely the “FOG” element is disabled. You need to enable it again.
    Show menu

NOTE: If you go to the “SHOW” menu while in the regular editor view, your fog will be enabled, so to change this setting you need to be in the Game View mode.

Hope that helps

1 Like