Download

Solution for SSR on edge of screen?

It’s probably how it works but it’s ugly. Is there a way to reduce that effect? I think I’ve tried everything.

Also. How would you setup reflections capture probe in a project lke that? beach with ocean. the camera is going to be above water and looking at the shore and it’s a night scene!
Should I place 1 big probe, many small probes or both?

getting reflections to look decent is the biggest challenge right now. My SSR is cranked to the max thanks to http://oliverm-h.blogspot.ca/2014/08/ue4-improving-ssr.html

It seems you have translucent water, so many reflection captures wouldn’t work in your case. There is no cubemap blending for lit translucency (Lit Translucency | Unreal Engine Documentation). So you have not so many ways to go: Ssr +20% - Rendering - Unreal Engine Forums Screen Space Reflections (SSR) Falloff - Rendering - Unreal Engine Forums post#8 . Or wait true planar reflections from EdWasHere Mirror shader - Work in Progress - Unreal Engine Forums or Epic Missing vital SceneCaptureReflectActor for real-time planar reflections - Feedback for Unreal Engine team - Unreal Engine Forums post #19 . Also there was some information about ssr in the Witcher 3, but I can’t find it

Thank you for your time man! Appreciated!

You’re welcome! Actually, you may try Epic’s implementation of planar reflections right now. Grab the latest master branch of UE4 from github, you’ll find new Planar Reflection actor there. Don’t forget to activate global clip plane for the project. Performance is pretty good, planar reflection eats 1.2-2 ms for my scene (25-50% quality)

Enable SSR in the material. It should blend cubemaps. What I found was the cubemaps were always too bright and the brightness setting on the reflection captures had no effect on translucent materials with SSR. To fix this as a hack I wrapped all my captures in darkening boxes. Otherwise I could never get the levels normalized correctly. I hide the darkening boxes in actual play, they are only there when building lighting and don’t cast shadows. I just used a multiplicative blending material to make it darker, you could use the same to make it brighter if you needed.

muchcharles, lit translucency doesn’t use cubemap blending, only one, closest reflection capture’s cubemap is applied Lit Translucency | Unreal Engine Documentation . It’s easy to make sure of that. Create opaque plane with glossy material, place few objects on top of it, few sphere/box reflection captures. Look around, from different angles. Change blend mode of the material to translucent. Look around and compare.