Download

Soft Shadows Problem - noob

Hey Guys !
I would appreciate if some of you could explain to me what em I doing wrong.
I try to get soft shadows, I turned on the Generate Mesh Distance Field under Settings<Rendering.
This is my result… The light has the Use Ray Traced DistanceField Shadow enabled.
Is there any other thing that I need to do to enable it ? I’ve restarted the editor after switching the Mesh Distance Field option too.

Here is a screenshot showing the problem :

Thank you for your help !
Lucas

I’m not sure whether you can use that with BSP, since with static meshes you control the distance field quality in the static mesh properties. Also, make sure your light radius is higher than 0, since it has to have a size.

Yeah, it does not work with BSP

Thank you so much for the quick answer !
I’ve changed the meshes to something I’ve done in 3ds max and there is still no soft shadows after I’ve built it … I’m clueless …

They are both right that Distance Fields do not support BSP. There are other limitations and features missing at the moment. This may be something that support is added for in the future, but ideally you would want to use static meshes for your final game as these are much more efficient than BSP geometry.

Thank you Tim, but I’ve used static meshes and have the same issue. It looks ok before the Build, after its still sharp from the edge to infinity.

I thought using the soft shadows in my arch-viz project. I saw the Paris Interior project and there was a lot of soft shadows in the corridor. But I did not managed to get the result…

Apologies for not seeing your post after zeOrb. I had started typing and went to do something and came back and posted at which point you had already posted yours. durh. oh well. Now to the troubleshooting! :smiley:

Distance Fields is a dynamic lighting solution and does not require lighting builds.

Looking at your settings you’ve got the light mobility set to Stationary, which doesn’t work with Distance Field Soft Shadows. Change this to Movable and make sure that Ray Traced Distance Fields are enabled, if not already.

Once you make the switch it should similar to this:

If you need to troubleshoot your mesh distance fields or the shadows look incorrect you can visualize the distance fields by going to Show > Visualize > Mesh Distance Fields in the viewport. This will show you a view like this:

5dea0bb9d1a03d56462ccc88e60bd47a820b6563.png

If you’re shadows look incorrect or your shadows have holes you can see here how the mesh distance fields are calculated in order to create your shadows. If you see any holes in your mesh you’ll want to increase the Distance Field Resolution. Only increase in single digit increments as this method is generating a mesh that the shadows will be based off of. Using higher values creates a more complex mesh for these shadow and is more expensive.

Eureka ! :smiley:
Thank you very much Tim ! I’m totally new to this and did not knew that it should be a movable light. Ok now I’m getting back to work ! :smiley:

No worries! Glad it’s working now! :smiley:

Ray Traced Distance Field Soft Shadows only works with point lights for me but not when using directional lights, what am i doing wrong as according to documentation it should work, i also tested it with one regular mesh and one bsp volume so i know when it works, i must have spent 6 hours or more today by trying to solve this so im happy for any help.