So the "realtime GI" is just pre-computed?

It doesn’t appear to be true global illumination until there is either baked lightmaps or some precomputed probes.
Have I missed something?
Disabling and enabling GI in a non-built scene looks like toggling cheap ambient light and not actual indirect lighting and shading. Certainly no colour bleeding.

There are a few methods to use global illumination right now. The actual always in realtime rendered one is just waay to expensive at this time.

However we are getting there and it’s fairly close to one. Yes it’s precomputed to a certain degree however it is still taking shaddows and changes in the environment in it into consideration in realtime.

Take a look at the documentation of lightmass (unreals light engine) for a fairly detailed explanation on how it works.


There is no existing Dynamic GI Solution in the pre-compiled engine, other than Light-Propagation Volumes (LPV’s), which can be enabled through some changes to the Config files of your engine installation. They are however being improved and eventually replaced with a new technique that Epic is working on right now, called DFGI. There’s a thread about it in the Rendering section.

nVidia’s VGXI has also been implemented by nVidia, and you can get that build of the engine from GitHub. VXGI recommends a GTX 900 series card, but it has been reported to run on lower spec cards.

Alright, that looks promising :slight_smile:

One more thing, an issue related to rendering that I am having right now.

Any idea why my GTX 580 is hitting 52 C for a blank scene like this?

My GPU typically idles at 33 C when no games are running.
And if I play games on lower graphics settings or older games, the temps are typically 38-45 C

For comparison, I get 45-50 C in DOTA 2 on highest graphics.

Or 55-65 in a game like Alien Isolation on highest graphics

UE4’s frames are limited to 62 FPS

So by comparison, you can see why I’m a bit concerned :stuck_out_tongue:

I am trying to switch over from Unity, and this is really the last thing that is really keeping me from making the switch.
Everything else about UE4 seems superior to me, but performance is definitely very important and I need to have confidence in UE4’s optimisation and performance.

I want to figure out what element remains costly even in a black void with a grid so I can determine if its necessary and can be disabled.

No worries, a few comments on this stuff so far:

You can unlock the Editor limit (62 FPS is a weird limit mind…) by using the console command (tilde key to open):

t.maxFPS 120

I use a 980 so I often set it to something insane like 250, and it still caps out :stuck_out_tongue: I’m not sure if this is relevant to you or not, but SLI currently yields no benefit to the Editor.

Second, the engine does tend to run quite hot on older cards. It has improved massively over time and will only continue to get better. I upgraded from a 560Ti not so long ago, and the heat difference in my room was certainly noticeable :P. It’s worth noting that all the additional draw calls and overhead for the editor do add a lot of processing to the card, you’ll get a surprisingly big frame-rate increase in a packaged build of your game, both GPU and CPU performance improve greatly. Closing editor panels that you’re not using can help performance too.

Hope this helps! It’s worth bearing in mind that the min recommended specs are considerably higher than the 580, (though I always found the 500 series held their power really well). All those supa-graphics don’t come free :stuck_out_tongue:

Found this on the FAQ - Häufig gestellte Fragen - Unreal Engine

A GTX 580 is powerful enough still for UE4. I cleaned the dust out of it and its made enough of a difference :stuck_out_tongue:

Can you please what build in the GitHub to get VXGI?

Thank you sir, I’m downloading it now. I work as a Mech/Civil I love doing renderings because it brings a project to life. VXGI might not be good for games just yet but for still pictures its perfect. They may add optimization to make it better.

Have you tried your empty scene game as standalone.exe with UE4 off?

be sure to click on little arrow in top-left corner of viewport and turn off realtime.
When enabled it continue to update scene even if you’re doing nothing