So the base rendering of the engine is a bit tough on my computer...

How would I disable all the fancy lighting and shadow effects so I can get a decent frame-rate while I create content?

Go to Quick Settings > Engine Scalability Settings and pick the one you are comfortable with.

Aha! Thank you!