Download

So shadows after Light bake until I individualy "apply changes"

Hi all,
I made a project with all shadows dynamic, no lightmass. Until it started to become heavy and slow on the GPU. Then I started changing some static meshes to have static light maintaining the dynamic light on foliage and grass.
My problem is that after I bake the light all my static meshes don’t show any shadows, until I go to the mesh details and on lod 0 (unique lod) change anything and click “apply changes” and then I have shadows for that mesh (on the meshes and on landscape). It happens everytime I bake

Note: I’m using 4.15.1

Thank you in advance

You need to use a stationary light for your directional light–that will allow it to generate dynamic shadows for dynamic objects while still generating baked shadows for static objects. For the static meshes, you need to make sure your lightmap UV’s are setup properly and that you have also adjusted the lightmap resolution to be high enough for the mesh.

Thank you darthviper107, I already had everything like you described so it was other thing.

The problem was that I had “Far Shadow Cascade Count” set to 1 (like in the image bellow ). So when I baked my light mass i thought it was doing it well but the shadow it was showing me was an dynamic shadow that only appeared after I changed the details of the static mesh (strange I think).
As soon as I changed the “Far Shadow Cascade Count” to 0 and rebaked, all the static shadows start appearing. what I think is strange is that the cascade shadow maps were disable so why was the “Far Shadow Cascade Count” value being used?

05c999c77d6bdbaa36fe5ddd46b9287eb926ddec.png