Download

Snow Tessellation Errors

Hi,

I have a snow material using tessellation and I’m getting errors on flat surfaces. Looks like some sort of clipping error. I also get material collection errors when I exit.

I set up my tessellation using the docs entry here: 1.11 - World Displacement | Unreal Engine Documentation

You can see the problem in this short video. It works fine on the unreal material orb props but not on the floors( using the starter content floor mesh ).

The snow function( credit: https://www.youtube.com/watch?v=IqqzKvBc9hc ):

http://i.imgur.com/SGLZOeJm.png

The material:

http://i.imgur.com/dmEqVMHm.png

The error:

http://i.imgur.com/FMYCOjgm.png

The level print:

http://i.imgur.com/oDdVAWcm.png

I’m new to the idea of tessellation and I’m obviously using it incorrectly. Or is it just that the floor mesh needs to have more triangles to start with? I was under the impression you could tessellate from a simple two-tri plane?

I fixed the reference error. I had deleted an actor that I was using the blueprint and forgotten about it. The tessellation flickering/vanishing still remains.

I would test it out using a mesh with more subdivisions. If that mesh is a single quad plane it might be causing this issue. Also are those boxes BSP brushes or static meshes? If it is BSP I would try converting it to a static mesh.

It doesn’t need a lot of subdivisions, try something like 10x10 quads to see if it makes a difference.

Hope that helps!

Yep, increasing the sub divisions fixed it. I should have tried that before posting.

Thanks, DotCam. :smiley: