Snow is falling through the roof

I made a particle system for snow and it’s working fine but when i made a small house the snow started falling through the roof. How can I fix that?

Hi Alekskn99,

Particle collision is determined by Scene Depth. This can only apply collision for particles based on what the scene depth sees in the screen. This means that the roof above your characters head cannot provide collision for what it cannot see.

There are a couple of ways to go about this. If your project is using Distance Fields you can easily change the GPU particle collision from scene depth to Distance Field. This will provide collision support regardless whether it is in the scene or not.

You can read more about that in the release notes here (Scroll down to the Distance Field with Particles section): What's New | Unreal Engine 5.1 Documentation

The alternative would be that you could set up a trigger volume that disables the particle system when you’re inside an area and enable when you leave the area.

I hope this helps.


Thanks a lot Tim :slight_smile:

I am having the same issue. The problem is that the house has a few large windows. That means that If i trigger the snow to stop falling inside the house, I will no longer be able to view the snow as it drops outside through my window from the inside.

Can you suggest a work around?


For the sake of efficiency and making sure that you’re not rendering something that does not need to be rendered when it’s not visible you could set up individual snow falling particles outside the windows that are triggered to start before you enter the room with the windows. This may seem “hacky” but it’s a legitimate development technique to not waste resources when not needed.

Games are really just a bunch of smoke and mirrors to get the effect you want. :slight_smile: