Download

Snappy Roads Blueprint Tool: Announce and Support Thread

Lets you quickly snap together a spline based road network.

**Marketplace Page: **https://www.unrealengine.com/marketp…blueprint-tool

SR_thumbnail_v2.jpg

This Blueprint allows you to use included or your own meshes to quickly add road infrastructure to your project. It can be used to create flexible roads, bridges and train tracks.

Features Demonstration / QuickTutorial Video: https://youtu.be/-Koi6tFwJ7M
Demo Level With Traffic Video: Procedural Spline Road And Highway Tool With Simple Vehicle Traffic - YouTube
Getting Started: Basic-Tutorial:-Creating-a-simple-road-network

This is support thread for Snappy Roads Blueprint Tool. I’ll try my best to answer any questions you may have. Feel free to leave your feedback and suggestions.

Just a quick video update

Hi
Is the end result a set of BP_Spline Meshes or a landscape spline(s) with mesh applied to each segment ?

Cheers

Paul_G

Hi
The end result is a BP_SnappyRoad Actor per road with a spline and multiple spline/static mesh components. They can be merged into a single static mesh for improved performance.

Hi thanks for the reply,

Paul G

You’re welcome!

Hi, is it possible to scale the road mesh without it distorting the extra objects such as lamp posts? I need to change the width of roads without it stretching objects such as lampposts which unfortunately is the end result if I stretch the road width. Thanks

Hi, yes it is possible to scale only the road mesh, steps are:

  • In the Content Browser duplicate road mesh(Ctrl+W)
  • Open duplicated mesh in Static Mesh Editor (Double Left Click)
  • In the details window go to the LOD 0 section -> Build Settings and adjust Build Scale Y paremeter
  • Click Apply Changes at the bottom of the LOD 0 section.
  • Save the mesh and assign it to a spline.
  • Done.

Intersections can be scaled in the same way.
I will add ScaleY paremeter in the upcoming update for easy scaling.

Hi, thanks for the advice. I’ve decided to workaround it by just creating my own road elements of all the different sizes I need, and using those instead of the existing road elements. It would be good to see the Scale Y parameter in there though as I’m sure many people will find it useful. :slight_smile:

Hello @GlimpseOfDawn I’ve been dreaming for a tool like Snappy Roads! There’s only one thing to make it perfect.
The possibility of making roads with elevations and snap the terrain to it, I mean not plane roads, but curves.
Is that possible?

Hello @Jkthrp, Thanks! Yes it is possible. That’s what “Apply Landscape Spline” button is for. Select all required roads. Make sure “Raise Terrain” option is checked and set “Deform Width” and “Falloff” parameters to somewhat large values (e.g. 2000, 1500 respectively for smooth hills). Then click “Apply Landscape Spline” button. You may then run “Align To Surface” function to level pavements with the landscape. And then run “Apply Landscape Spline” again with smaller values (e.g. 250, 50) to carve the roads.

Please note, I’ve found a few bugs which may prevent this functions from working properly with such large values. Fixes are going to be included in the next update.

@GlimpseOfDawn Thank you for your answer! I followed your instructions but I can’t make it work, I’ve uploaded a video showing it.
Am I missing something or it’s something you have to fix?

@Jkthrp Yes, this is the bug I’m talking about.

@Jkthrp The fix has been submitted. All should work as intended now. Please allow a few days for the file update to be processed.

@GlimpseOfDawn Great! I’ll download it as soon as it’s available!

Hello, I don’t know what i am doing wrong but I follow your instruction tutorial, but my 3rd person character falls through any elevated roads. I have no collision with any road I build. I even created a new project from scratch, built a road and place the 3rd person on it and they just fall to the ground. Same thing happens also with your showcase map you included also where you show the elevated roads, still no collision. Any ideas what I am doing wrong?

Hello @Jkthrp, File update has been processed, the fix is live.

@jjacks888 Hello, this is because Road Actor’s Spline->CollisionPreset property is set to “OverlapAll” by default. Set it to “BlockAll” to enable collision. You may also want to set “Use Complex Collision As Simple” in Static Mesh Editor for road and intersection meshes.

Thank you for the update @GlimpseOfDawn That bug is fixed, GREAT! Now I want the terrain height to match with the sidewalk, when it’s plane works fine, but not with an uneven road.
Maybe there’s a value I can modify or something…

You are welcome @Jkthrp! You need to run “Align To Surface” function with ‘-23’ offset to level pavements with the landscape. And then run “Apply Landscape Spline” again with smaller values (e.g. 250, 50) to carve the roads.

Good news everyone! Big feature update is finally live on the Marketplace! Here is new video:https://www.youtube.com/watch?v=cL5JC1uSvog