Smoke not blocked by mesh

I got a torch burning in a building, the floor above is set to “block all”, but the smoke penetrates through the floor mesh, visible in the layer above.

Is this a bug, missing feature, or do i have to do something else to block the smoke? The smoke is from a particle system without collision settings.

You need to add a collision module to the emitter in Cascade and set collision behavior to Kill.

Thank You Jacky!