Download

slow internet connection using unreal

When I launch the software, the connection to the internet becomes very very slow-as if most of the network resources are going to use the software.
In addition, i get flickering screen in the software window.
Please help.
Thank you. Roy

p.s: i am new here.

windows 7 prof, gtx titan
INTEL CORE I7 4790 1333MHZ
24GB DDR3 1600MHZ
3000GB 7200RPM
256GB SSD

It doesn’t make much sense that your internet should slow down because of UE.
What kind of connection are you on?

Try downloading the free version of Net balancer and check how much bandwidth UE (and other softwares) are using: NetBalancer - internet traffic control tool for Windows
There is a fairly simple guide on how to use it here: http://www.howtogeek.com/howto/43713/how-to-monitor-the-bandwidth-consumption-of-individual-applications/

Also, you got your CPU frequency wrong, should be around 4.40 GHz :slight_smile: 1333MHz is most likely what your RAM is running on (unless you overclocked it).

It’s not the engine that is a internet hog, it’s the darned launcher.

Thaks for the reply

my cpu frequency is 3.6 ghz (and not as i wrote- sorry) so the flickering is not from this. how can i avoid the launcher connecting to the internet ( if he cause the slow connection)?
sorry for the rookie question :slight_smile:

Thanks
roy

If the launcher is actually causing the problem, you can always turn it off once you opened your project.
Seems really strange that the launcher should use enough to slow down your internet, unless you have a really slow connection normally.
You could try doing a www.speedtest.net with and without the launcher and see if there is any noticeable difference.

Use offline mode. You can find this button when you login to the launcher.

I have the same issue, very slow connection when the editor is running, youtube, skype file sending, http browsing etc … every thing run very slow… if I close the launcher or set in offline, it change nothing …
as soon as I close the editor, things go back to normal … any idea ? (I’m using the editor since october and I’ve ran into the issue since day one … :s ) I’m glad to see I’m not the only one …

The internet slowdown is really odd, I don’t have any issues with that whatsoever. But it could possibly be caused by UE4 using up resources, making other apps run slowly, which can make it seem like the internet is slow when really it is the program.

Go to Edit - > Editor Preferences and select the Miscellaneous tab, there will be a setting named “Use less CPU when in background”. Make sure this option is turned on. It makes a big difference when using other programs with the editor open.

See if that helps! :slight_smile:

nop, I use lot of other softwares like 3dsmax, or zbrush, while the editor is running, I use to push my computer to its limit, and its performance doesn’t change if the editor is running or not … just the internet connection is slow (even steam download doesn’t go over 100 KB/s instead of 1.2 MB/s when the editor is closed …)

Any good news about this issue?

nothing new here … any ideas ?

Hi All,
roysgi, is the slowdown your experiencing on the launcher or in the engine? Just wanted to make sure we’re all on the same page here.

-Max B.

Hi Max.
The slowdown continue even i close the launcher. after shutdown the engine-the internet connection become stable and quick as before.

Thanks
Roy

I can confirm this. I have had this issue with the launcher since day one. Every time I start the unreal launcher it brings my internet connection to it’s knees. Even browsing the internet while the unreal engine launcher is active is impossible for me. Seems to me there’s a major flaw in the launcher that takes all the bandwidth available. The even stranger part is that i’m on a 180Mbit connection allowing me to download with 22MB/s the launcher itself how ever doesn’t go faster than a few hundred KB’s if I’m lucky (100/300KB’s max)

alright, can you try a small test to narrow down the culprit?

Either unplug your ethernet cable or disable you internet connection and see if there is any difference. There is an offline mode in the launcher you can select at the sign-in screen, from there you should be able to open your engine and see if there is a difference in performance.

-Max B.

I am having the same problem. When I start editor about 10 mins later internet page loading takes forever so internet dies. I started offline mode even closed the launcher when using the engine, also unplugged my ethernet cable and disabled/enabled the adapter and restarted the modem. Nothing helped except for closing the editor and then in 2-3 minutes internet turned back to normal. That’s a pretty weird issue, not sure what causes that.
my maindobard has amd760g chipset with Realtek 8111D/E ethernet chip.
using amd phenomII x4 955be 3.2ghz cpu and radeon 7890le tahiti gpu.

Are you downloading anything from the launcher?

Either online or offline mode in the launcher doesn’t make any difference, or terminating launcher exe either… As I stated in my post above.

I found a few more things;

  • internet connection doesn’t affected when the editor works in background, the editor worked in the background for 30min and internet hasn’t interrupted. (no never ending page loads or yellow exclamation mark on the connection icon at right bottom)
  • internet beginning to interrupt when I actually do something with the editor i.e. working on and compiling materials, baking lightmaps and fiddling in the staticmesh browser.
  • also it seems like the engine using only one core in editor (%25percent usage in taskmanager) and it can go up %30percent when baking lightmaps. still pretty low, I have amd phenomII am3 socket quad core.

I’m not even sure where to start looking, some hints appreciated.

Having the same problem, except last time it happened the internet connection suffered so bad it won’t even ping anything and it didn’t recover after I closed the editor, I had to restart my machine.

I’ve checked resource monitor and turns out the internet connection is simply in permanent idle with short spikes of 100 KB worth of transmission every once in a while. It doesn’t just hogging up resources, it makes the very OS to flat out refuse to work.

Windows 8.1 64
AMD FX 4350
ASRock 990FX Killer
Gigabyte R9 280X