Download

slow internet connection using unreal

This problem seems very similar to mine, so I wanted to chime in. I just downloaded the Epic Games Launcher, and am trying to install Unreal Engine 4. Every time I attempt to download UE4 however, it reaches about 100KB or so then fails. Even worse, I can’t browse the internet for a while after this happens! I looked at the router’s status page, and it says my IP Address is 0.0.0.0 – meaning something has reset it.

I chalked it up to my ISP being odd at first, but this has consistently happened about four times, each right after I attempted to download UE4. Restarting the router and the modem didn’t help. I saw an old WoW thread where the WoW launcher was “crashing” the user’s internet access in a similar way and disabling UPnP helped them; but this didn’t solve my issue either.

And lastly, this is a fresh install of Windows 8.1 – literally installed the OS last night.

Specs:
Windows 8.1 64-bit
Intel Core i7 950 @ 3.07 GHz
AMD Radeon HD 6800

Router is Cisco Linksys E1200.

EDIT: I’m looking into this as a general issue now instead of just an Epic Launcher issue. Apparently if the Epic Launcher is using a peer-to-peer method for downloading, it could trigger anti-DOS protections in my router. A common thread I’m finding is that if someone has a high transfer speed and a lot of peers they’re downloading from, their router will shut down for a moment. I don’t see anything in the launcher that indicates if this is the case, and unfortunately the launcher has no settings I can find (either in the program or in the launcher directory)…

EDIT 2: I managed to fix this problem! I fixed it by following an AnswerHub post directing me to an *.ini file; if anyone thinks digging in there might help them, the AnswerHub that helped me out is here.

Was a solution to this issue ever found? I am having a similar issue.

Me too. I reinstalled Windows and now it’s happening (it wasn’t before, but my SSD died so I had to reinstall).
I guess reinstalling Windows will change the things. Or it’s your hard drive (even if it doesn’t seem to be any reason that the hard drive makes the Internet slower). Idk, but that’s what happened to me, now that I’m on a HDD the Internet dies every time I open UE4.

Opened UE4 v4.9 never slowed the internet itself for me, but the whole Unreal server has been slow for me specially wiki, answer hub, marketplace and launcher are very slow for me.

That’s always slow for me, even with UE4 closed…
:slight_smile:

Oops I forgot to mention the slowness of Unreal sites does not depend on unreal 4 is opened or not for me.
Here’s my thread I created few days back - Unreal Server is so slow for me - General Discussion - Unreal Engine Forums

Same issue for me and my brother as well, we both use Comcast high-speed internet service if that helps any.

Have the same problem.

After starting the ‘Epic Games Launcher’ or after canceling the download of the ‘Unreal Engine’, it uses my internet connection to its fullest.

My workaround:
Open the ‘Windows Task-Manager’ and kill ‘UnrealCEFSubProcess.exe’ several times. Problem solved.

i have this issue since 2014, been using UE4 again more lately, and its begining to nag me, the UnrealCEFSubProcess shutdown works, but it still would be nice to know what exactly is causing this, and a response from epic if possible on when this will be fixed ?

I am having the exact same issue. Ued destroys my bandwidth, skype and web sites can barely connect and drop connection often. Just did a clean re-install of Windows 10 hoping to solve the problem, no luck.

Hi just wanted to add that this fix actually works. I suspect some ISPs around the world don’t like the way Unreal Launcher uses bandwidth.

I added the following lines to my DefaultEngine.ini ( located at C:\Program Files (x86)\Epic Games\Launcher\Portal\Config):
[Portal.BuildPatch]
ChunkDownloads=2
ChunkRetries=20
RetryTime=1

I’m also having this issue. Tried adding the aformentioned entries into defaultengine.ini, and closing Epic Launcher as soon as UE launches. No dice.

Like others, about 5-10 minutes with UE open, my internet is completely killed, and I have a fairly decent broadband connection. If I close UE, I get internet access back after a few minutes.

So I used some networking tools to find that Unreal Engine is, over the course of about 5 minutes, uploading ~400kb of data and downloading ~80kb of data over UDP, at which point the internet is snuffed out. I enabled Windows firewall, and set some rules to block the traffic, and that seems to have fixed the problem.

It’s still all very odd. I’ve never had an issue like this. Usually disabling the firewall fixes issues, not the other way around. What is the traffic for, anyway? Does UE have some sort of cloud or P2P functionality that my ISP is interpreting as nefarious or something?

Hi,

I have the same issue, but I can’t seem to be able to set the rules properly to block the traffic.
Could you please tell me specifically which programs you blocked?

Thank you.

@cgcodycg @BadKam

In general regarding this topic, you can find background info / practical advice in other threads like these:

1 2 3 4

Disabling the Launcher is easy. Its only needed for downloading engine versions or Marketplace content.
The latter on Windows btw… There is an alternative Community-Based Linux-Downloader you can try too.
The success of Fortnite & Tencent’s commercial holding, means the probability of more ‘Analytics’ is high.
So between this, Microsoft’s sneakiness and Cryptolocker attacks, consider dev’ing on Air-Gapped PC’s:wink:

In addition to what @franktech mentioned, once your project is loaded you can exit the launcher, it’s no longer needed.

Thanks for the advise, fellas. Launcher isn’t the issue, however. At least in my case, ue4editor.exe and swarmagent.exe are the culprits. Anyway, with all inbound and outbound network traffic blocked for these two processes via Windows Firewall, I’ve fixed the problem, even with the Launcher open and actively downloading something. I’m not doing any network swarm computing anyway, so it’s fixed enough for my needs. :slight_smile:

**Hi all,

The launcher was also the issue for me.
I had to block with Windows Firewall (inbound and outbound):

  • the Epic launcher
  • the Unreal engine
  • the Swarm agent
    to get it to work without reducing my bandwidth to non-existent.

Special thanks to you cgcodycg for your help and taking the time to answer me.
I did block both the launcher and the engine, but I was missing the swarm agent :wink:

Thanks again, now I can watch a tutorial while working :D**