Download

Slow Frame Rate

Hello all,

I am trying to get my frame rate up. Not in the editor but in the final product. All I can get to right now is about 40 fps. I have a quadro 5000 and dual 6 core xeons. I only get about 40 fps even if it is the simple first person shooter template.
Is there a why i can reduce the resolution or AA or something in the final game to bring these numbers up. I need to get to 70 to work with the rift so any help would be greatly appreciated. All my lights are static but it seems like i am missing something. Please help

Thank you,
Darius

What exactly do you have in your level?

Also make sure to turn down some quality settings -> e.g you can use console commands for that :slight_smile:

sg.AntiAliasingQuality (1-4)
sg.EffectsQuality (1-4)
sg.PostProcessQuality (1-4)
sg.ShadowQuality (1-4)
sg.TextureQuality (1-4)
sg.ViewDistanceQuality (1-4)
r.ScreenPercentage (1-100)
r.MaterialQualityLevel (0-1)

right now it is just an archviz setup

So i moved all of the suggested above to 1 and got to about 40 fps ofcourse with awful quality

Well the Quadro 5000 gets worse performance than a GTX 480 or a GTX 750 Ti in 3dmark, it’s not really a great GPU for a modern game engine.

Yeah I was afraid of that ZacD. That’s why I was wondering if I could reduce the resolution or something to help with it.

man even the straight up FPS shoot template I can only get around 30 fps. Is there some lighting things i can turn off to. I am not sure what the overhead is that is slowing it down but it does not seem it is the geometry or textures in my scene.

There may not be a way to get around the fact that it’s not really a gaming pc. Something to try: Go to the Settings, and go to Engine Scalability settings. Setting everything to Low or Medium should give at least a little improvement.

doing the Engine scalability. Does this effect the final packaged game or only effect it in the editor?

Before packaging I would put the scalability back to “Epic” just to be safe, but it should only affect the editor.

Quardos & Xeons are great at pre-rendering scenes, but awful at running them in realtime. If you’re migrating over to UE4 then you may wish to consider a second PC.

A Xeon is fine for gaming, it’s just not very cost effective. As for Quadros, I’m not really sure why they don’t work so well for games. They’re good for running 3D programs like Maya or 3ds Max, but not games–though you’d think that a 3D program viewport is pretty similar to a game.

Thank for your help. I just tested it on a AMD firepro 7000, i got it up to 60 fps but i guess it still would be better on a gaming video card. Unfortunately I need to run this off of a laptop. Presentation is on Tuesday :confused:

DotCam. I would like the setting be passed onto the packaged file because that is the one i am going to use to present and that is the one i need to get high FPS on, not the in editor. In editor works fine for me at 30 fps but when i package it and use the rift it gets slow so I would want the packaged file to be faster.

Ah apologies I assumed you mean the other way around.

In that case you will want to change the settings in the *.ini files that contain the preset settings, the following guide should help you decide which settings to change:
https://docs.unrealengine.com/latest/INT/Engine/Performance/Rendering/Scalability/ScalabilityReference/index.html

Looking through the guide, you should be able to use the scalability settings menu to set these options as well, lower the setting to med or low and try quickly packaging up the game, the settings should be retained.